[bug#33217] Modifying the commit message to gnu-Add-r-weights

Message ID CA+H0LRPUC6aok5ChepcHbjjoV_rcLnNmJq80kCcz7YOvxXWwKQ@mail.gmail.com
State Accepted
Headers show
Series [bug#33217] Modifying the commit message to gnu-Add-r-weights | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Lakshmi Prasannakumar Nov. 1, 2018, 6:14 p.m. UTC
Hi,

Adding line breakers to the patch file. Please find the patch file attached
to this mail.

Thanks and Regards,
Lakshmi Prasannakumar
Bangalore


On Thu, Nov 1, 2018 at 6:22 PM Lakshmi Prasannakumar <
lakshmiprasannakumaran@gmail.com> wrote:

> Hi,
> Please find the attached patch file with this mail.
> The changes made are to the cran.scm
> * gnu/packages/cran.scm (r-weights): New variable.
>
> Thanks,
> Lakshmi Prasannakumar
> Bangalore
>

Patch

From 74abc72a7e22a03714d1ead77768536e651d54f3 Mon Sep 17 00:00:00 2001
From: lakshmi <lakshmiprasannakumaran@gmail.com>
Date: Wed, 31 Oct 2018 09:57:31 +0530
Subject: [PATCH] gnu: Add r-weights 

gnu/packages/cran.scm (r-weights): New variable
 

---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7f2123b..fc95aaa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6693,3 +6693,27 @@  component analysis and correlation matrices, cluster analyses, scatter plots,
 stacked scales, effects plots of regression models (including interaction
 terms) and much more.  This package supports labelled data.")
     (license license:gpl3)))
+
+(define-public r-weights
+(package
+  (name "r-weights")
+  (version "1.0")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (cran-uri "weights" version))
+      (sha256
+        (base32
+          "0186bfpkhxngrshac6bpg37alp6slwhwd43inrm8hqg0vhpfgc4c"))))
+  (build-system r-build-system)
+  (propagated-inputs
+    `(("r-gdata" ,r-gdata)
+      ("r-hmisc" ,r-hmisc)
+      ("r-mice" ,r-mice)))
+  (home-page
+    "http://cran.r-project.org/web/packages/weights")
+  (synopsis "Weighting and weighted statistics")
+  (description
+    "This package provides a variety of functions for producing simple weighted statistics, such as weighted Pearson's correlations, partial correlations, Chi-Squared statistics, histograms, and t-tests. It also includes some softwares used for quickly recoding survey data and plotting point estimates from interaction terms in regressions which can be then multiplied with imputed regressions. Weighted partial correlation calculations are pulled to address a bug.")
+  (license gpl2+)))
+
-- 
2.9.3