[bug#33217] Adding r-weights patch file

Message ID CA+H0LROLf0uRCM2jDgeoCZVj-ALmWRfd+M6W2evsdEVGj8eskQ@mail.gmail.com
State Accepted
Headers show
Series [bug#33217] Adding r-weights patch file | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Lakshmi Prasannakumar Oct. 31, 2018, 5:25 p.m. UTC
Hi ,
I'm modifying the patch file name to match the coding standards and sending
it across.

Thanks,
Lakshmi Prasannakumar
Bangalore

Patch

From 061eb74487dc8234108b2aa3733a2065ca9bb70e Mon Sep 17 00:00:00 2001
From: lakshmi <lakshmiprasannakumaran@gmail.com>
Date: Wed, 31 Oct 2018 09:57:31 +0530
Subject: [PATCH 3/3] gnu: Add r-weight

---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7f2123b..fc95aaa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6693,3 +6693,27 @@  component analysis and correlation matrices, cluster analyses, scatter plots,
 stacked scales, effects plots of regression models (including interaction
 terms) and much more.  This package supports labelled data.")
     (license license:gpl3)))
+
+(define-public r-weights
+(package
+  (name "r-weights")
+  (version "1.0")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (cran-uri "weights" version))
+      (sha256
+        (base32
+          "0186bfpkhxngrshac6bpg37alp6slwhwd43inrm8hqg0vhpfgc4c"))))
+  (build-system r-build-system)
+  (propagated-inputs
+    `(("r-gdata" ,r-gdata)
+      ("r-hmisc" ,r-hmisc)
+      ("r-mice" ,r-mice)))
+  (home-page
+    "http://cran.r-project.org/web/packages/weights")
+  (synopsis "Weighting and weighted statistics")
+  (description
+    "This package provides a variety of functions for producing simple weighted statistics, such as weighted Pearson's correlations, partial correlations, Chi-Squared statistics, histograms, and t-tests. It also includes some softwares used for quickly recoding survey data and plotting point estimates from interaction terms in regressions which can be then multiplied with imputed regressions. Weighted partial correlation calculations are pulled to address a bug.")
+  (license gpl2+)))
+
-- 
2.9.3