[bug#33214] Patch file for weight package

Message ID CA+H0LRNAX0U9jmz1xvyuWiseR1Hvaqchm17qQsco4vP0suxvqw@mail.gmail.com
State Accepted
Headers show
Series [bug#33214] Patch file for weight package | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Lakshmi Prasannakumar Oct. 31, 2018, 4:38 a.m. UTC
Hi,

Please find the attached patch file for adding weight package from cran
repository.

Thanks,
Lakshmi Prasannakumar
Bangalore

Comments

Lakshmi Prasannakumar Oct. 31, 2018, 9:29 a.m. UTC | #1
Hi Gábor,

I'm sending an email with the tracker no. cc-ing both of you. This is the
number I received from the bug tracker. Below is the link from the bug
tracker.
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=33214

Do let me know if I need to commit again and create a patch file, as this
was the first time I committed, I'm not completely sure if it was right or
not.

Thanks,
Lakshmi Prasannakumar
Bangalore
Gábor Boskovits Oct. 31, 2018, 10:18 a.m. UTC | #2
Hello Laksmi,

Lakshmi Prasannakumar <lakshmiprasannakumaran@gmail.com> ezt írta
(időpont: 2018. okt. 31., Sze, 10:30):
>
> Hi Gábor,
>
> I'm sending an email with the tracker no. cc-ing both of you. This is the number I received from the bug tracker. Below is the link from the bug tracker.
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=33214
>

Thanks for the tracker id. I did not find it because I was looking in
a slightly wrong way (I was looking for r-weight) :)

In guix, there is a convention on the commit messages, you can see it
in git log, it is also
documented in the coding conventions.

In this case it should look something like this:

gnu: Add r-weight.

* gnu/packages/cran.scm (r-weight): New variable.

You can modify the commit message using git commit --amend, then
create a new patch and send that.

I will test this package, and report back later.



> Do let me know if I need to commit again and create a patch file, as this was the first time I committed, I'm not completely sure if it was right or not.
>
> Thanks,
> Lakshmi Prasannakumar
> Bangalore
Gábor Boskovits Nov. 6, 2018, 3:23 p.m. UTC | #3
This has made to master on commit cddc0300b7fb5fbbc80f45a626073f8372bf491f.

Thanks for all the hard work!

Patch

From fc22007a28621824b5aa06deb7c64823f1b0fcc9 Mon Sep 17 00:00:00 2001
From: lakshmi <lakshmiprasannakumaran@gmail.com>
Date: Wed, 31 Oct 2018 09:57:31 +0530
Subject: [PATCH] Adding the package weights for using weighted statistics
 functions

---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7f2123b..fc95aaa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6693,3 +6693,27 @@  component analysis and correlation matrices, cluster analyses, scatter plots,
 stacked scales, effects plots of regression models (including interaction
 terms) and much more.  This package supports labelled data.")
     (license license:gpl3)))
+
+(define-public r-weights
+(package
+  (name "r-weights")
+  (version "1.0")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (cran-uri "weights" version))
+      (sha256
+        (base32
+          "0186bfpkhxngrshac6bpg37alp6slwhwd43inrm8hqg0vhpfgc4c"))))
+  (build-system r-build-system)
+  (propagated-inputs
+    `(("r-gdata" ,r-gdata)
+      ("r-hmisc" ,r-hmisc)
+      ("r-mice" ,r-mice)))
+  (home-page
+    "http://cran.r-project.org/web/packages/weights")
+  (synopsis "Weighting and weighted statistics")
+  (description
+    "This package provides a variety of functions for producing simple weighted statistics, such as weighted Pearson's correlations, partial correlations, Chi-Squared statistics, histograms, and t-tests. It also includes some softwares used for quickly recoding survey data and plotting point estimates from interaction terms in regressions which can be then multiplied with imputed regressions. Weighted partial correlation calculations are pulled to address a bug.")
+  (license gpl2+)))
+
-- 
2.9.3