diff mbox series

[bug#53751,staging] gnu: git: Update to 2.35.1.

Message ID CA+3U0Znv=MRHvmfWVRUWm-86zC6tz2rk+dCmzHP5-tC1BpCrXQ@mail.gmail.com
State Accepted
Headers show
Series [bug#53751,staging] gnu: git: Update to 2.35.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Feb. 3, 2022, 3:31 p.m. UTC
Tested build with dependent packages with 'git' in the name:
./pre-inst-env guix refresh -l git | cut -d: -f2- | tr ' ' '\n' | grep git
| xargs ./pre-inst-env guix build

Patches are both attached and inlined below.


From 5ed6fcda2fa6aff6e6c2a3a0b771153fad2f3633 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 3 Feb 2022 13:25:51 +0000
Subject: [PATCH 1/2] gnu: git: Update to 2.35.1.

* gnu/packages/version-control.scm (git): Update to 2.35.1.
---
 gnu/packages/version-control.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Maxim Cournoyer April 4, 2022, 4:25 a.m. UTC | #1
Hello,

Greg Hogan <code@greghogan.com> writes:

> Tested build with dependent packages with 'git' in the name:
> ./pre-inst-env guix refresh -l git | cut -d: -f2- | tr ' ' '\n' | grep git
> | xargs ./pre-inst-env guix build
>
> Patches are both attached and inlined below.

Thanks!  Applied as 223a3d7f7fdb6af9c4c090785cab15d38680e887 and
367048036d8337a8dd8cfbbd277086286d8b0b40 to the master branch (it was
just 37 packages shy over our packages count guideline).

Closing.

Maxim
diff mbox series

Patch

From 6fbb70ce36a290a1a475eaa88bc86a0024917ba6 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 3 Feb 2022 15:24:22 +0000
Subject: [PATCH 2/2] gnu: stgit: Update to 1.5.

* gnu/packages/version-control.scm (stgit): Update to 1.5.
---
 gnu/packages/version-control.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 797c9437f9..e28349299b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1320,7 +1320,7 @@  (define-public git-flow
 (define-public stgit
   (package
     (name "stgit")
-    (version "1.1")
+    (version "1.5")
     (source
      (origin
        (method git-fetch)
@@ -1329,7 +1329,7 @@  (define-public stgit
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1jp74qsgw3f9c8xgaaqvmhfh4ar3n1ns5ncm8glvqyywlxldxi0n"))))
+        (base32 "1igljjpdgl4na1a5hi0nmg36ph0hw6hw8hhq5436fgcl8yjimyz3"))))
     (build-system python-build-system)
     (native-inputs
      (list perl))
-- 
2.34.0