diff mbox series

[bug#53786,core-updates] gnu: boost: Update to 1.78.0.

Message ID CA+3U0Znnrx_CrP=OK6p7ySA6uFkqboCn-+HQLQoe33cwZib6WA@mail.gmail.com
State Accepted
Headers show
Series [bug#53786,core-updates] gnu: boost: Update to 1.78.0. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Feb. 4, 2022, 9:08 p.m. UTC
Patch inlined and attached.


From 2c0c5f67f4d3f9ab3c8d2130f92a8059bf9d69ed Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 3 Feb 2022 17:54:31 +0000
Subject: [PATCH] gnu: boost: Update to 1.78.0.

* gnu/packages/boost.scm (boost): Update to 1.78.0.
[source](patches): Add upstream patch.
---
 gnu/packages/boost.scm | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)

 ;;; This file is part of GNU Guix.
@@ -68,15 +67,21 @@ (define (boost-patch name version hash)
 (define-public boost
   (package
     (name "boost")
-    (version "1.77.0")
+    (version "1.78.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "
https://boostorg.jfrog.io/artifactory/main/release/"
                                   version "/source/boost_"
                                   (version-with-underscores version)
".tar.bz2"))
+              (patches
+               (list (boost-patch
+                      ;; 1.78.0 was released with a faulty installation
routine:
+                      ;; <https://github.com/bfgroup/b2/pull/113>.
+                      "0001-b2-fix-install.patch" version
+
 "02ljm22a4gcaj10xng8ww8aifrrlzm1pgyp08c06fd75f9pbkrbi")))
               (sha256
                (base32
-                "0m08hhk3l7zvzajyk39qlw566q3fhixayhc2j11328qf0gy8b7zw"))))
+                "1k5w6l3xsa9vipwk14sjb1vhsj88xwz7jr964996rcmxsisz30c6"))))
     (build-system gnu-build-system)
     (inputs (list icu4c zlib))
     (native-inputs

Comments

Ludovic Courtès March 28, 2022, 7:31 a.m. UTC | #1
Hi,

Greg Hogan <code@greghogan.com> skribis:

>>From 2c0c5f67f4d3f9ab3c8d2130f92a8059bf9d69ed Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Thu, 3 Feb 2022 17:54:31 +0000
> Subject: [PATCH] gnu: boost: Update to 1.78.0.
>
> * gnu/packages/boost.scm (boost): Update to 1.78.0.
> [source](patches): Add upstream patch.

Applied to ‘core-updates’, thanks!

Ludo’.
diff mbox series

Patch

From 2c0c5f67f4d3f9ab3c8d2130f92a8059bf9d69ed Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 3 Feb 2022 17:54:31 +0000
Subject: [PATCH] gnu: boost: Update to 1.78.0.

* gnu/packages/boost.scm (boost): Update to 1.78.0.
[source](patches): Add upstream patch.
---
 gnu/packages/boost.scm | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index b53b1f4257..2373dd9feb 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -15,9 +15,8 @@ 
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
-;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -68,15 +67,21 @@  (define (boost-patch name version hash)
 (define-public boost
   (package
     (name "boost")
-    (version "1.77.0")
+    (version "1.78.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
                                   version "/source/boost_"
                                   (version-with-underscores version) ".tar.bz2"))
+              (patches
+               (list (boost-patch
+                      ;; 1.78.0 was released with a faulty installation routine:
+                      ;; <https://github.com/bfgroup/b2/pull/113>.
+                      "0001-b2-fix-install.patch" version
+                      "02ljm22a4gcaj10xng8ww8aifrrlzm1pgyp08c06fd75f9pbkrbi")))
               (sha256
                (base32
-                "0m08hhk3l7zvzajyk39qlw566q3fhixayhc2j11328qf0gy8b7zw"))))
+                "1k5w6l3xsa9vipwk14sjb1vhsj88xwz7jr964996rcmxsisz30c6"))))
     (build-system gnu-build-system)
     (inputs (list icu4c zlib))
     (native-inputs
-- 
2.34.0