diff mbox series

[bug#45298] gnu: openblas: Update to 0.3.13.

Message ID CA+3U0ZniPZRrptY3unRTtmDH_Yf8BUu=E1XsNGuLoxAE41mZzQ@mail.gmail.com
State Accepted
Headers show
Series [bug#45298] gnu: openblas: Update to 0.3.13. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Dec. 17, 2020, 2:57 p.m. UTC
For the core-updates branch.

From 65b3d40ac240a184c51a2e0ad2b2106f0d3bd830 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Tue, 15 Dec 2020 19:56:04 +0000
Subject: [PATCH] gnu: openblas: Update to 0.3.13.

* gnu/packages/maths.scm (openblas): Update to 0.3.13.
---
 gnu/packages/maths.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Dec. 22, 2020, 2:21 p.m. UTC | #1
Hi,

Greg Hogan <code@greghogan.com> skribis:

> For the core-updates branch.

[...]

> +    (version "0.3.13")
>      (source
>       (origin
>         (method url-fetch)
> @@ -3637,7 +3637,7 @@ parts of it.")
>         (file-name (string-append name "-" version ".tar.gz"))
>         (sha256
>          (base32
> -         "14iz9xnrb9xiwgj84j94mc74gg0zn2vsy9fmsijxxma1n7dck4w3"))))
> +         "09rx33yaa48lwsdd1yyvzfgfpzjmjzldkzgn751qbpqdp42ba8wj"))))

I get:

--8<---------------cut here---------------start------------->8---
sha256 hash mismatch for /gnu/store/01vmivah7fwf5q16zpbybnbq2mqrz9w2-openblas-0.3.13-checkout:
  expected hash: 09rx33yaa48lwsdd1yyvzfgfpzjmjzldkzgn751qbpqdp42ba8wj
  actual hash:   14jxh0v3jfbw4mfjx4mcz4dd51lyq7pqvh9k8dg94539ypzjr2lj
hash mismatch for store item '/gnu/store/01vmivah7fwf5q16zpbybnbq2mqrz9w2-openblas-0.3.13-checkout'
--8<---------------cut here---------------end--------------->8---

Could you take a look and see if this is because the Git tag was changed
in place?

Also, ‘core-updates’ is now at 0.3.10 so the patch didn’t apply out of
the box.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c118e9e25c..2e30349956 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3628,7 +3628,7 @@  parts of it.")
 (define-public openblas
   (package
     (name "openblas")
-    (version "0.3.9")
+    (version "0.3.13")
     (source
      (origin
        (method url-fetch)
@@ -3637,7 +3637,7 @@  parts of it.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "14iz9xnrb9xiwgj84j94mc74gg0zn2vsy9fmsijxxma1n7dck4w3"))))
+         "09rx33yaa48lwsdd1yyvzfgfpzjmjzldkzgn751qbpqdp42ba8wj"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"