diff mbox series

[bug#53785] gnu: lldb: Update to 13.0.1.

Message ID CA+3U0ZnOCkBQTDya07Bin2S-P0C7p9tWO0ehgYoAPVaS67UD2w@mail.gmail.com
State Accepted
Headers show
Series [bug#53785] gnu: lldb: Update to 13.0.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Feb. 4, 2022, 8:57 p.m. UTC
I could not tell if lldb had been overlooked during the LLVM 13 update or
if there was a reason that this package was left behind.

Patch inline and attached.


From 6b10197220bd789d0dc0bd1131717d6ae46f46c1 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Fri, 4 Feb 2022 20:52:37 +0000
Subject: [PATCH] gnu: lldb: Update to 13.0.1.

* gnu/packages/llvm.scm (lldb): Update to 13.0.1.
[inputs]: Change from LLVM-12 and CLANG-12 to LLVM-13 and CLANG-13.
---
 gnu/packages/llvm.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès Feb. 10, 2022, 10:21 p.m. UTC | #1
Hi,

Greg Hogan <code@greghogan.com> skribis:

> I could not tell if lldb had been overlooked during the LLVM 13 update or
> if there was a reason that this package was left behind.

I suppose there was no specific reason.  But AIUI, it’s not necessary to
update in lockstep either, right?

>>From 6b10197220bd789d0dc0bd1131717d6ae46f46c1 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Fri, 4 Feb 2022 20:52:37 +0000
> Subject: [PATCH] gnu: lldb: Update to 13.0.1.
>
> * gnu/packages/llvm.scm (lldb): Update to 13.0.1.
> [inputs]: Change from LLVM-12 and CLANG-12 to LLVM-13 and CLANG-13.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 6b10197220bd789d0dc0bd1131717d6ae46f46c1 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Fri, 4 Feb 2022 20:52:37 +0000
Subject: [PATCH] gnu: lldb: Update to 13.0.1.

* gnu/packages/llvm.scm (lldb): Update to 13.0.1.
[inputs]: Change from LLVM-12 and CLANG-12 to LLVM-13 and CLANG-13.
---
 gnu/packages/llvm.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 64b4e7521d..b6d52402a8 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1204,21 +1205,21 @@  (define-public lld-as-ld-wrapper
 (define-public lldb
   (package
     (name "lldb")
-    (version "12.0.1")
+    (version "13.0.1")
     (source (origin
               (method url-fetch)
               (uri (llvm-uri "lldb" version))
               (sha256
                (base32
-                "0g3pj1m3chafavpr35r9fynm85y2hdyla6klj0h28khxs2613i78"))))
+                "05nvcbgb4rx860r3jzsbpvcbzpd0i7nsm5qrpkyfhg5vrh5mj32a"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-DCMAKE_CXX_COMPILER=clang++")))
     (native-inputs
      (list pkg-config swig))
     (inputs
-     (list clang-12
-           llvm-12
+     (list clang-13
+           llvm-13
            ;; Optional (but recommended) inputs.
            ncurses
            libedit
-- 
2.34.0