diff mbox series

[bug#46562] gnu: gperftools: Update to 2.8.1.

Message ID CA+3U0ZnHNWeQAirGrn40seYsAF8QazLsGNHZWv-XLaWgSH-o+w@mail.gmail.com
State Accepted
Headers show
Series [bug#46562] gnu: gperftools: Update to 2.8.1. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Feb. 16, 2021, 1:47 p.m. UTC
From cc9e4c7fdfb872685181715def0d14d35069f76d Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 11 Feb 2021 19:08:35 +0000
Subject: [PATCH] gnu: gperftools: Update to 2.8.1.

* gnu/packages/cpp.scm (gperftools): Update to 2.8.1.
---
 gnu/packages/cpp.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Feb. 16, 2021, 7:04 p.m. UTC | #1
On Tue, Feb 16, 2021 at 08:47:23AM -0500, Greg Hogan wrote:
> From cc9e4c7fdfb872685181715def0d14d35069f76d Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Thu, 11 Feb 2021 19:08:35 +0000
> Subject: [PATCH] gnu: gperftools: Update to 2.8.1.
> 
> * gnu/packages/cpp.scm (gperftools): Update to 2.8.1.

Thanks for the patch!

I applied it and tried to build gperftools, but it fails like this:

------
[...]
FAIL: heap-checker_debug_unittest.sh
PASS: tcmalloc_unittest.sh
PASS: profiler_unittest.sh
============================================================================
Testsuite summary for gperftools 2.8.1
============================================================================
# TOTAL: 48
# PASS:  47
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See ./test-suite.log
Please report to gperftools@googlegroups.com
============================================================================
make[2]: *** [Makefile:6446: test-suite.log] Error 1
make[2]: Leaving directory '/tmp/guix-build-gperftools-2.8.1.drv-0/source'
make[1]: *** [Makefile:6554: check-TESTS] Error 2
make[1]: Leaving directory '/tmp/guix-build-gperftools-2.8.1.drv-0/source'
make: *** [Makefile:7105: check-am] Error 2

Test suite failed, dumping logs.

--- ./test-suite.log --------------------------------------------------------

========================================
   gperftools 2.8.1: ./test-suite.log
========================================

# TOTAL: 48
# PASS:  47
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: heap-checker_debug_unittest.sh
====================================

Testing ./heap-checker_unittest with HEAPCHECK= ... OK
Testing ./heap-checker_unittest with HEAPCHECK=local ... OK
Testing ./heap-checker_unittest with HEAPCHECK=normal ... OK
Testing ./heap-checker_unittest with HEAPCHECK=strict ... ./heap-checker_debug_unittest.sh: line 64: /tmp/heap_check_info/output: No such file or directory
FAILED
Output from the failed run:
----
cat: /tmp/heap_check_info/output: No such file or directory
----
FAIL heap-checker_debug_unittest.sh (exit status: 4)


command "make" "check" "-j" "4" failed with status 2
builder for `/gnu/store/f99c263cwa45jhv6fa7g507ff3bplpq6-gperftools-2.8.1.drv' failed with exit code 1
build of /gnu/store/f99c263cwa45jhv6fa7g507ff3bplpq6-gperftools-2.8.1.drv failed
------
Efraim Flashner Feb. 18, 2021, 7:58 a.m. UTC | #2
On Tue, Feb 16, 2021 at 02:04:34PM -0500, Leo Famulari wrote:
> On Tue, Feb 16, 2021 at 08:47:23AM -0500, Greg Hogan wrote:
> > From cc9e4c7fdfb872685181715def0d14d35069f76d Mon Sep 17 00:00:00 2001
> > From: Greg Hogan <code@greghogan.com>
> > Date: Thu, 11 Feb 2021 19:08:35 +0000
> > Subject: [PATCH] gnu: gperftools: Update to 2.8.1.
> > 
> > * gnu/packages/cpp.scm (gperftools): Update to 2.8.1.
> 
> Thanks for the patch!
> 
> I applied it and tried to build gperftools, but it fails like this:
> 
> ------
> [...]
> FAIL: heap-checker_debug_unittest.sh
> PASS: tcmalloc_unittest.sh
> PASS: profiler_unittest.sh
> ============================================================================
> Testsuite summary for gperftools 2.8.1
> ============================================================================
> # TOTAL: 48
> # PASS:  47
> # SKIP:  0
> # XFAIL: 0
> # FAIL:  1
> # XPASS: 0
> # ERROR: 0
> ============================================================================
> See ./test-suite.log
> Please report to gperftools@googlegroups.com
> ============================================================================
> make[2]: *** [Makefile:6446: test-suite.log] Error 1
> make[2]: Leaving directory '/tmp/guix-build-gperftools-2.8.1.drv-0/source'
> make[1]: *** [Makefile:6554: check-TESTS] Error 2
> make[1]: Leaving directory '/tmp/guix-build-gperftools-2.8.1.drv-0/source'
> make: *** [Makefile:7105: check-am] Error 2
> 
> Test suite failed, dumping logs.
> 
> --- ./test-suite.log --------------------------------------------------------
> 
> ========================================
>    gperftools 2.8.1: ./test-suite.log
> ========================================
> 
> # TOTAL: 48
> # PASS:  47
> # SKIP:  0
> # XFAIL: 0
> # FAIL:  1
> # XPASS: 0
> # ERROR: 0
> 
> .. contents:: :depth: 2
> 
> FAIL: heap-checker_debug_unittest.sh
> ====================================
> 
> Testing ./heap-checker_unittest with HEAPCHECK= ... OK
> Testing ./heap-checker_unittest with HEAPCHECK=local ... OK
> Testing ./heap-checker_unittest with HEAPCHECK=normal ... OK
> Testing ./heap-checker_unittest with HEAPCHECK=strict ... ./heap-checker_debug_unittest.sh: line 64: /tmp/heap_check_info/output: No such file or directory
> FAILED
> Output from the failed run:
> ----
> cat: /tmp/heap_check_info/output: No such file or directory
> ----
> FAIL heap-checker_debug_unittest.sh (exit status: 4)
> 
> 
> command "make" "check" "-j" "4" failed with status 2
> builder for `/gnu/store/f99c263cwa45jhv6fa7g507ff3bplpq6-gperftools-2.8.1.drv' failed with exit code 1
> build of /gnu/store/f99c263cwa45jhv6fa7g507ff3bplpq6-gperftools-2.8.1.drv failed
> ------
> 

Did you try sending it through again? It built without any problems on
my machine (with more cores)
Leo Famulari Feb. 18, 2021, 6:04 p.m. UTC | #3
On Thu, Feb 18, 2021 at 09:58:39AM +0200, Efraim Flashner wrote:
> Did you try sending it through again? It built without any problems on
> my machine (with more cores)

Yeah, it fails consistently on my i5-6300U [0], using a tmpfs for the build
directory on Linux 5.11.

It works when I set #:parallel-tests? #f, so I've pushed Greg's patch
with that modification as 7cd0247eb4d22d47f76e26fd7b65ec45cb5d7ccb

[0] 2 cores, "4 threads"
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ae47490755..10d756a564 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -512,7 +512,7 @@  maintained anymore.")
 (define-public gperftools
   (package
     (name "gperftools")
-    (version "2.8")
+    (version "2.8.1")
     (source
      (origin
        (method git-fetch)
@@ -520,7 +520,7 @@  maintained anymore.")
              (url "https://github.com/gperftools/gperftools")
              (commit (string-append "gperftools-" version))))
        (sha256
-        (base32 "1rnc53kaxlljgbpsff906vdsry9jl9gcvcnmxgkprwzxq1wipyd0"))
+        (base32 "19bj2vlsbfwq7m826v2ccqg47kd7cb5vcz1yw2x0v5qzhaxbakk1"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (native-inputs