diff mbox series

[bug#45367] gnu: intel-mpi-benchmarks: Update to 2019.6.

Message ID CA+3U0Zn-mYcx+L-dHSSkd4CuqC3Xeq486wnyXkF0m4+h7=PQBQ@mail.gmail.com
State Accepted
Headers show
Series [bug#45367] gnu: intel-mpi-benchmarks: Update to 2019.6. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Dec. 22, 2020, 11:29 a.m. UTC
I submitted an upstream pull request for the patched execute permissions
issue.

From da0d408ecd1f57283990bb8747dffa4447f4c8f2 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Sun, 20 Dec 2020 13:19:04 +0000
Subject: [PATCH] gnu: intel-mpi-benchmarks: Update to 2019.6.

* gnu/packages/benchmarks.scm (intel-mpi-benchmarks): Update to 2019.6.
[origin]: Add fix for file permissions.
---
 gnu/packages/benchmark.scm | 13 +++++++++++--
 1 file changed, 11 insertions(+), 2 deletions(-)

               (uri (git-reference
@@ -137,7 +138,15 @@ is to write a job file matching the I/O load one wants
to simulate.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0si5xi6ilhd3w0gbsg124589pvp094hvf366rvjjb9pi7pdk5p4i"))))
+                "02hxbk9g9nl59bk5qcfl3djj7b58vsqys340m1xdbyqwcrbnahh9"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; Some source configuration files in the original
tarball
+                  ;; have inappropriate execute permissions, which
interferes
+                  ;; with the install phase below
+                  (for-each (lambda (file) (chmod file #o444)) (find-files
"WINDOWS" "."))
+                  #t))))
     (build-system gnu-build-system)
     (inputs
      `(("mpi" ,mpi)))

Comments

Ludovic Courtès Dec. 22, 2020, 2:11 p.m. UTC | #1
Hi,

Greg Hogan <code@greghogan.com> skribis:

>>From da0d408ecd1f57283990bb8747dffa4447f4c8f2 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Sun, 20 Dec 2020 13:19:04 +0000
> Subject: [PATCH] gnu: intel-mpi-benchmarks: Update to 2019.6.
>
> * gnu/packages/benchmarks.scm (intel-mpi-benchmarks): Update to 2019.6.
> [origin]: Add fix for file permissions.

Applied after tweaking the indentation of the long line.  Thanks!

(The patch had been mangled on its way but I was able to “repair” it.)

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 61aa42c420..78a1e8bceb 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -8,6 +8,7 @@ 
 ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 malte Frank Gerdes <malte.f.gerdes@gmail.com>
+;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -128,7 +129,7 @@  is to write a job file matching the I/O load one wants
to simulate.")
                          (if (string=? (package-name mpi) "openmpi")
                              ""
                              (string-append "-" (package-name mpi)))))
-    (version "2019.3")
+    (version "2019.6")
     (source (origin
               (method git-fetch)