diff mbox series

[bug#45698] gnu: python-numpy: Update to 1.19.4.

Message ID CA+3U0Zmwmhkuq5VfL_uu9dL5Hd12v4jrktmK6v6_Ho+5dqC8rQ@mail.gmail.com
State Accepted
Headers show
Series [bug#45698] gnu: python-numpy: Update to 1.19.4. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan March 14, 2021, 4:03 p.m. UTC
Replacement patch for more recent version.

From bc7e702f26a7f1e9ff22cd9c3cd3f6c12dc72bdf Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Sun, 14 Mar 2021 15:40:41 +0000
Subject: [PATCH] gnu: python-numpy: Update to 1.20.1.

* gnu/packages/python-xyz.scm (python-numpy): Update to 1.20.1.
[native-inputs]: Add python-hypothesis.
---
 gnu/packages/python-xyz.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

        (method url-fetch)
@@ -4551,13 +4552,14 @@ between language specification and implementation
aspects.")
              version "/numpy-" version ".tar.gz"))
        (sha256
         (base32
-         "1ak9dmjja0q90a7fsxli51ypcwssh8c4pb6f8wkrsnf2xgdk6dy9"))))
+         "0vc4fr3429a1rrzfxbd05lifrh72bwcc5vavwlwr5jmlxdlivxcv"))))
     (build-system python-build-system)
     (inputs
      `(("openblas" ,openblas)
        ("lapack" ,lapack)))
     (native-inputs
      `(("python-cython" ,python-cython)
+       ("python-hypothesis" ,python-hypothesis)
        ("python-pytest" ,python-pytest)
        ("gfortran" ,gfortran)))
     (arguments
--
2.30.2

On Wed, Jan 6, 2021 at 1:46 PM Greg Hogan <code@greghogan.com> wrote:

> From f5f390689908f065fd12abaeba8fa4e19e5e96c8 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Tue, 5 Jan 2021 16:23:24 +0000
> Subject: [PATCH] gnu: python-numpy: Update to 1.19.4.
>
> * gnu/packages/python-xyz.scm (python-numpy): Update to 1.19.4.
> [native-inputs]: Add python-hypothesis.
> ---
>  gnu/packages/python-xyz.scm | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index ab10668a01..a049f257cb 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -94,6 +94,7 @@
>  ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
>  ;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
>  ;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
> +;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -4515,7 +4516,7 @@ between language specification and implementation
> aspects.")
>  (define-public python-numpy
>    (package
>      (name "python-numpy")
> -    (version "1.17.3")
> +    (version "1.19.4")
>      (source
>       (origin
>         (method url-fetch)
> @@ -4524,13 +4525,14 @@ between language specification and implementation
> aspects.")
>               version "/numpy-" version ".tar.gz"))
>         (sha256
>          (base32
> -         "1ak9dmjja0q90a7fsxli51ypcwssh8c4pb6f8wkrsnf2xgdk6dy9"))))
> +         "04w46xsllj7al9bfjk5zzs48xa9y300yzjh3ysrxnf38bml6m0zy"))))
>      (build-system python-build-system)
>      (inputs
>       `(("openblas" ,openblas)
>         ("lapack" ,lapack)))
>      (native-inputs
>       `(("python-cython" ,python-cython)
> +       ("python-hypothesis" ,python-hypothesis)
>         ("python-pytest" ,python-pytest)
>         ("gfortran" ,gfortran)))
>      (arguments
> --
> 2.30.0
>

Comments

Xinglu Chen March 14, 2021, 9:04 p.m. UTC | #1
On Sun, Mar 14 2021, Greg Hogan wrote:

> * gnu/packages/python-xyz.scm (python-numpy): Update to 1.20.1.
> [native-inputs]: Add python-hypothesis.

Great, Numpy builds for me, but when I try to build Scipy which is often
used with Numpy, one test for Matplolib is failing.  Any ideas?

--8<---------------cut here---------------start------------->8---
=================================== FAILURES ===================================
___________________________________ test_gca ___________________________________

    def test_gca():
        fig = plt.figure()
    
        ax1 = fig.add_axes([0, 0, 1, 1])
        assert fig.gca(projection='rectilinear') is ax1
        assert fig.gca() is ax1
    
        ax2 = fig.add_subplot(121, projection='polar')
        assert fig.gca() is ax2
        assert fig.gca(polar=True) is ax2
    
        ax3 = fig.add_subplot(122)
        assert fig.gca() is ax3
    
        # the final request for a polar axes will end up creating one
        # with a spec of 111.
        with warnings.catch_warnings(record=True) as w:
            warnings.simplefilter('always')
            # Changing the projection will throw a warning
            assert fig.gca(polar=True) is not ax3
>           assert len(w) == 1
E           assert 2 == 1
E             -2
E             +1

/gnu/store/s3i6ps5fmyb5ld0rx37g23s7w8rzghl7-python-matplotlib-3.1.2/lib/python3.8/site-packages/matplotlib/tests/test_figure.py:168: AssertionError

[...]

-- Docs: https://docs.pytest.org/en/latest/warnings.html
= 1 failed, 5014 passed, 2139 skipped, 2 deselected, 9 xfailed, 8 xpassed, 36 warnings in 107.78s (0:01:47) =
command "python" "tests.py" "-v" "-m" "not network and not webagg" failed with status 1
builder for `/gnu/store/6kmizr8498mxiv7spsavznirva76yphh-python-matplotlib-3.1.2.drv' failed with exit code 1
build of /gnu/store/6kmizr8498mxiv7spsavznirva76yphh-python-matplotlib-3.1.2.drv failed
View build log at '/var/log/guix/drvs/6k/mizr8498mxiv7spsavznirva76yphh-python-matplotlib-3.1.2.drv.bz2'.
cannot build derivation `/gnu/store/hd6zbcgdf7sa9bj63rsw5ayyhrrlfndw-python-scipy-1.6.0.drv': 1 dependencies couldn't be built
guix build: error: build of `/gnu/store/hd6zbcgdf7sa9bj63rsw5ayyhrrlfndw-python-scipy-1.6.0.drv' failed
--8<---------------cut here---------------end--------------->8---
Simon Tournier March 15, 2021, 8:34 a.m. UTC | #2
Hi,

On Sun, 14 Mar 2021 at 22:04, Xinglu Chen <public@yoctocell.xyz> wrote:
> On Sun, Mar 14 2021, Greg Hogan wrote:
>
>> * gnu/packages/python-xyz.scm (python-numpy): Update to 1.20.1.
>> [native-inputs]: Add python-hypothesis.
>
> Great, Numpy builds for me, but when I try to build Scipy which is often
> used with Numpy, one test for Matplolib is failing.  Any ideas?

On my side, the update of numpy breaks other dependant packages too.

All the best,
simon
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dadf08f03d..f4e742b4fe 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,6 +99,7 @@ 
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 Ellis Kenyő <me@elken.dev>
 ;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4542,7 +4543,7 @@  between language specification and implementation
aspects.")
 (define-public python-numpy
   (package
     (name "python-numpy")
-    (version "1.17.3")
+    (version "1.20.1")
     (source
      (origin