diff mbox series

[bug#43343] gnu: Add cxxopts.

Message ID CA+3U0ZmeNHUhjMHbnXBQDV4vCOUWy6A5EcMPCvDWUoDuN3wEoA@mail.gmail.com
State Accepted
Headers show
Series [bug#43343] gnu: Add cxxopts. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Greg Hogan Sept. 18, 2020, 2:22 p.m. UTC
Mathieu,

My apologies, when you had noted this issue on the other update I had
intended to check this submission as well.

From c8298882f74839fac9bcbf42a9e491d6bc5605e8 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Fri, 18 Sep 2020 14:20:46 +0000
Subject: [PATCH] gnu: Add cxxopts.

* gnu/packages/cpp.scm (cxxopts): New variable.
---
 gnu/packages/cpp.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Mathieu Othacehe Sept. 18, 2020, 2:46 p.m. UTC | #1
> My apologies, when you had noted this issue on the other update I had intended to check this submission as well.

No worries. Another small detail, when you are adding some text to a
patch sent with git send-email, you can do so below the "---" mark, so
that it is not added to the commit message when applying with git.

Pushed this one, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 003883e1a5..90e139e9eb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -647,3 +648,24 @@  Google's C++ code base.")
 a zero-dependency C++ header-only parser combinator library for creating
 parsers according to a Parsing Expression Grammar (PEG).")
     (license license:expat)))
+
+(define-public cxxopts
+  (package
+    (name "cxxopts")
+    (version "2.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jarro2783/cxxopts")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d3y747lsh1wkalc39nxd088rbypxigm991lk3j91zpn56whrpha"))))
+    (build-system cmake-build-system)
+    (synopsis "Lightweight C++ command line option parser")
+    (description
+     "A lightweight header-only C++ option parser library, supporting the
+standard GNU style syntax for options.")
+    (home-page "https://github.com/jarro2783/cxxopts/wiki")
+    (license license:expat)))