diff mbox series

[bug#46770] gnu: Add caf.

Message ID CA+3U0ZmDgQSEsM=SU+pRZk6io9MT5XiZzHKH1MN6bLppjsiCdQ@mail.gmail.com
State Accepted
Headers show
Series [bug#46770] gnu: Add caf. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Feb. 25, 2021, 2:38 p.m. UTC
From 3ea6fefe7e48bcf6ea3997faabdcbe415c607479 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Wed, 24 Feb 2021 14:13:13 +0000
Subject: [PATCH] gnu: Add caf.

* gnu/packages/cpp.scm (caf): New variable.
---
 gnu/packages/cpp.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

+    (home-page "https://www.actor-framework.org/")
+    (license license:bsd-3)))

Comments

Leo Famulari Feb. 25, 2021, 7:43 p.m. UTC | #1
On Thu, Feb 25, 2021 at 09:38:02AM -0500, Greg Hogan wrote:
> From 3ea6fefe7e48bcf6ea3997faabdcbe415c607479 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Wed, 24 Feb 2021 14:13:13 +0000
> Subject: [PATCH] gnu: Add caf.
> 
> * gnu/packages/cpp.scm (caf): New variable.

Thanks! Pushed as f16168744e8d5ab30cc77919cc06389c3f4a6abe
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 685dc02fca..659eb1cdeb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -954,3 +954,29 @@  conversions to and from strings, iteration and related
functionality.")
 feature set with a simple and intuitive interface.")
     (home-page "https://cliutils.github.io/CLI11/book/")
     (license license:bsd-3)))
+
+(define-public caf
+  (package
+    (name "caf")
+    (version "0.18.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "
https://github.com/actor-framework/actor-framework")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1c3spd6vm1h9qhlk5c4fdwi6nbqx5vwz2zvv6qp0rj1hx6xpq3cx"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags
+       '("-DCAF_ENABLE_EXAMPLES=OFF")))
+    (inputs
+     `(("openssl" ,openssl)))
+    (synopsis "C++ implementation of the actor model")
+    (description "The C++ Actor Framework (CAF) offers a high-level C++17
+programming environment using the actor model for concurrent, distributed
+computation.")