diff mbox series

[bug#43913,4/4] gnu: Add aws-sdk-cpp.

Message ID CA+3U0ZksXLwwf5NdA0NThowN+MT7BY_Vh7oUNbeaCc7Q3OtPBA@mail.gmail.com
State Changes Requested
Headers show
Series gnu: Add aws-sdk-cpp. | expand

Commit Message

Greg Hogan Oct. 10, 2020, 7:14 p.m. UTC
From 29da385ef4c5d164d479a86925260784a819b897 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Sat, 10 Oct 2020 17:52:19 +0000
Subject: [PATCH 4/4] gnu: Add aws-sdk-cpp.

* gnu/packages/cpp.scm (aws-sdk-cpp): New variable.
---
 gnu/packages/cpp.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

+    (home-page "https://github.com/awslabs/aws-c-event-stream")
+    (license license:asl2.0)))
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 680a2ad520..3d3cc74c69 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -42,10 +42,12 @@ 
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages c)
   #:use-module (gnu packages check)
   #:use-module (gnu packages code)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crypto)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libunwind)
@@ -730,3 +732,37 @@  of C++14 components which complements @code{std} and
Boost.")
     ; 32bit is not supported: https://github.com/facebook/folly/issues/103
     (supported-systems '("aarch64" "x86_64-linux"))
     (license license:asl2.0)))
+
+(define-public aws-sdk-cpp
+  (package
+    (name "aws-sdk-cpp")
+    (version "1.8.65")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url (string-append "https://github.com/awslabs/"
name))
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "057arm6c98hckbg0q5l9zr58659igysmx8nx4fgxcr4qrkdadh9l"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(;; Tests are run during the build phase.
+       #:tests? #f
+       #:configure-flags
+       '("-DBUILD_SHARED_LIBS=OFF"
+         "-DBUILD_DEPS=OFF")))
+    (propagated-inputs
+     `(("aws-c-common" ,aws-c-common)
+       ("aws-c-event-stream" ,aws-c-event-stream)))
+    (inputs
+     `(("aws-checksums" ,aws-checksums)
+       ("curl" ,curl)
+       ("openssl" ,openssl)
+       ("zlib" ,zlib)))
+    (synopsis "AWS SDK for C++")
+    (description
+     "The AWS SDK for C++ provides a C++11 interface for AWS.")