diff mbox

[bug#45843,0/2] gnu: bcc: Update to 0.18.0.

Message ID CA+3U0Zkp41cSB-YjDJn1Q5fOeZQO1ohLy7N_5Cseq-=Xd+rDJw@mail.gmail.com
State Accepted
Headers show

Commit Message

Greg Hogan Jan. 28, 2021, 5:03 p.m. UTC
Thank you for verifying this. Is there a way to select and locally build a
full (but small) set of package dependents?

bpftrace, bcc, and libbpf only compile for me with libbpf 0.1.1 and bcc
0.16.0. New patches below and attached.


From a785056285c7cf4995ca905acb7317e25d7ec801 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Tue, 12 Jan 2021 19:56:31 +0000
Subject: [PATCH 1/2] gnu: libbpf: Update to 0.1.1.

* gnu/packages/linux.scm (libbpf): Update to 0.1.1.
[arguments]: Remove obsolete deletion.
---
 gnu/packages/linux.scm | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)

Comments

Efraim Flashner Jan. 28, 2021, 6:28 p.m. UTC | #1
On Thu, Jan 28, 2021 at 12:03:57PM -0500, Greg Hogan wrote:
> Thank you for verifying this. Is there a way to select and locally build a
> full (but small) set of package dependents?

I have a script I use that uses fold-packages to find the packages which
directly have a specific package as an input. I'm trying to get it to
work with inputs, but for now I manually edit it to add the package and
run it guile. I've attached it.

> bpftrace, bcc, and libbpf only compile for me with libbpf 0.1.1 and bcc
> 0.16.0. New patches below and attached.

Thanks, it all looks good now. Patches pushed.
diff mbox

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2735c67200..f22008dcbf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -49,7 +49,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Anders Thuné <asse.97@gmail.com>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2020 David Dashyan <mail@davie.li>
 ;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
@@ -7587,7 +7587,7 @@  persistent over reboots.")
 (define-public libbpf
   (package
     (name "libbpf")
-    (version "0.0.9")
+    (version "0.1.1")
     (source
      (origin
        (method git-fetch)
@@ -7597,7 +7597,7 @@  persistent over reboots.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "18l0gff7nm841mwhr7bc7x863xcyvwh58zl7mc0amnsjqlbrvqg7"))))
+         "0ilnnm4q22f8fagwp8kb37licy4ks861i2iqh2djsypqhnxvx3fv"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -7618,9 +7618,6 @@  persistent over reboots.")
          (delete 'configure)
          (add-before 'build 'pre-build
            (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "scripts/check-reallocarray.sh"
-               (("/bin/rm" rm)
-                (string-append (assoc-ref inputs "coreutils") rm)))
              (chdir "src")
              #t)))))
     (home-page "https://github.com/libbpf/libbpf")
-- 
2.30.0



From 480ebd33111e1a85e3855974ebbd87ecbd6c6f25 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Tue, 12 Jan 2021 19:56:57 +0000
Subject: [PATCH 2/2] gnu: bcc: Update to 0.16.0.

* gnu/packages/linux.scm (bcc): Update to 0.16.0.
---
 gnu/packages/linux.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f22008dcbf..6066a7a4c8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7631,7 +7631,7 @@  headers.")
 (define-public bcc
   (package
     (name "bcc")
-    (version "0.15.0")
+    (version "0.16.0")
     (source
      (origin
        (method git-fetch)
@@ -7641,7 +7641,7 @@  headers.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1d5j9zanffa1c7lpi5fcrdlx1n7hy86xl82fam2xqr0s41q4ipxw"))))
+         "1367c0bzrpclvjvmk0sxgi49rh7j2f9izqk5a7g3yvawh1fmvvjh"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("bison" ,bison)