diff mbox series

[bug#44242] gnu: git: Update to 2.29.1.

Message ID CA+3U0Zk8eynyz8n9qboohzf5CKDbCoDhmHH5aJ_Sa0izPxNwaQ@mail.gmail.com
State Accepted
Headers show
Series [bug#44242] gnu: git: Update to 2.29.1. | expand

Checks

Context Check Description
cbaines/submitting builds fail
cbaines/applying patch fail View Laminar job

Commit Message

Greg Hogan Oct. 26, 2020, 4:38 p.m. UTC
From 0225825ec6853d77bc0e72e41c9e9b49fd0609ee Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Mon, 26 Oct 2020 16:00:32 +0000
Subject: [PATCH] gnu: git: Update to 2.29.1.

* gnu/packages/version-control.scm (git): Update to 2.29.1.
---
 gnu/packages/version-control.scm | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

                (let* ((out     (assoc-ref outputs "out"))

Comments

Leo Famulari Oct. 26, 2020, 5:41 p.m. UTC | #1
On Mon, Oct 26, 2020 at 12:38:59PM -0400, Greg Hogan wrote:
> From 0225825ec6853d77bc0e72e41c9e9b49fd0609ee Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Mon, 26 Oct 2020 16:00:32 +0000
> Subject: [PATCH] gnu: git: Update to 2.29.1.
> 
> * gnu/packages/version-control.scm (git): Update to 2.29.1.

Thank you for this patch! However, I updated our Git package to 2.29.1
with the same changes only yesterday:

https://git.savannah.gnu.org/cgit/guix.git/commit/?id=375ef50ce63c5ed552973cab3619d055d7b41b99
Greg Hogan Oct. 26, 2020, 5:47 p.m. UTC | #2
> Thank you for this patch! However, I updated our Git package to 2.29.1
> with the same changes only yesterday:
> 
> https://git.savannah.gnu.org/cgit/guix.git/commit/?id=375ef50ce63c5ed552973cab3619d055d7b41b99

Ah, I must have rebased and searched the patches just before the commit went in :) Thanks for the update and noticing this duplicate.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm
b/gnu/packages/version-control.scm
index 0e0e59d1a2..036c0fa09b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -159,14 +159,14 @@  as well as the classic centralized workflow.")
 (define-public git
   (package
    (name "git")
-   (version "2.28.0")
+   (version "2.29.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://kernel.org/software/scm/git/git-"
                                 version ".tar.xz"))
             (sha256
              (base32
-              "17a311vzimqn1glc9d7x82rhb1mb81m5rr4g8xji8idaafid39fz"))))
+              "1cxd2h0k6bhv25avnk40h0pahgc7vgs37dc6kmln3pfhjyb6019h"))))
    (build-system gnu-build-system)
    (native-inputs
     `(("native-perl" ,perl)
@@ -183,7 +183,7 @@  as well as the classic centralized workflow.")
                 version ".tar.xz"))
           (sha256
            (base32
-            "1dvwq0py8a2ywmgc5pzdlsj3608s7r9wyba292728fcs3yj7ynk6"))))
+            "1gn7fhh8qfgfwr0gbgzwv1wncrvhc9iic9fg9sbns44kxa59biyk"))))
       ;; For subtree documentation.
       ("asciidoc" ,asciidoc-py3)
       ("docbook-xsl" ,docbook-xsl)
@@ -518,11 +518,6 @@  everything from small to very large projects with
speed and efficiency.")
            (delete 'install-man-pages)
            (delete 'install-subtree)
            (delete 'install-credential-netrc)
-           (add-before 'check 'delete-svn-test
-             (lambda _
-               ;; This test cannot run since we are not building 'git-svn'.
-               (delete-file "t/t9020-remote-svn.sh")
-               #t))
            (add-after 'install 'remove-unusable-perl-commands
              (lambda* (#:key outputs #:allow-other-keys)