diff mbox series

[bug#45727] gnu: folly: Update to 2021.01.04.00.

Message ID CA+3U0Zk53XbQk0bP=rOuU_65YdDf2yyVQXfNH8RGjv8PsqVgLA@mail.gmail.com
State Accepted
Headers show
Series [bug#45727] gnu: folly: Update to 2021.01.04.00. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Jan. 26, 2021, 9:55 p.m. UTC
Turns out this was an issue with Boost 1.75 (which I had patched over from
core-updates, requiring the C++20 support). I feel like I might as well
post the simple Folly version bump here and the core-updates Boost patch in
the following reply. Not sure when core-updates will be merged or if Boost
1.76 will be out by then.

From 334fc83ae2a3d92ba7813150709532b252592817 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 7 Jan 2021 21:54:37 +0000
Subject: [PATCH] gnu: folly: Update to 2021.01.25.00.

* gnu/packages/cpp.scm (folly): Update to 2021.01.25.00.
---
 gnu/packages/cpp.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Ludovic Courtès Jan. 26, 2021, 10:31 p.m. UTC | #1
Hi,

Greg Hogan <code@greghogan.com> skribis:

> Turns out this was an issue with Boost 1.75 (which I had patched over from
> core-updates, requiring the C++20 support). I feel like I might as well
> post the simple Folly version bump here and the core-updates Boost patch in
> the following reply. Not sure when core-updates will be merged or if Boost
> 1.76 will be out by then.

Sounds good to me.

>>From 334fc83ae2a3d92ba7813150709532b252592817 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Thu, 7 Jan 2021 21:54:37 +0000
> Subject: [PATCH] gnu: folly: Update to 2021.01.25.00.
>
> * gnu/packages/cpp.scm (folly): Update to 2021.01.25.00.

Applied to ‘master’, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ca8f7a9f80..73a3ceb2df 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -14,7 +14,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
-;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -689,7 +689,7 @@  standard GNU style syntax for options.")
 (define-public folly
   (package
     (name "folly")
-    (version "2020.10.05.00")
+    (version "2021.01.25.00")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -698,7 +698,7 @@  standard GNU style syntax for options.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0q4w4cvjxffc462hvs8h4zryq4965j7015zvkwagcm6cj6wmz3cn"))))
+                "14dl1g6vf7mc90mcync5h2lp14fwcx8n9h91pmiq6rfgv1fjjrwz"))))
     (build-system cmake-build-system)
     (arguments
      '(;; Tests must be explicitly enabled