diff mbox series

[bug#45842] Acknowledgement ([PATCH] gnu: abseil-cpp: Update to 20200923.2.)

Message ID CA+3U0Z=z+CNkR8Zv7N09kh7v0HJPyQnsV_Gj7mdDErjdK2Y+4A@mail.gmail.com
State Accepted
Headers show
Series [bug#45842] Acknowledgement ([PATCH] gnu: abseil-cpp: Update to 20200923.2.) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Feb. 1, 2021, 2:14 p.m. UTC
Another version bump.

From 4153f16143405a4439cabe8c13f3b75440e1f1cc Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Mon, 1 Feb 2021 14:01:11 +0000
Subject: [PATCH] gnu: abseil-cpp: Update to 20200923.3.

* gnu/packages/cpp.scm (abseil-cpp): Update to 20200923.3.
[arguments]: Enable external googletest.
* gnu/packages/patches/abseil-cpp-fix.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
---
 gnu/local.mk                              |  1 +
 gnu/packages/cpp.scm                      |  7 +++++--
 gnu/packages/patches/abseil-cpp-fix.patch | 16 ++++++++++++++++
 3 files changed, 22 insertions(+), 2 deletions(-)
 create mode 100644 gnu/packages/patches/abseil-cpp-fix.patch

+ TYPED_TEST_SUITE_P(UniquePtrModifiersTest);
+
--
2.30.0

On Wed, Jan 13, 2021 at 10:13 AM GNU bug Tracking System <
help-debbugs@gnu.org> wrote:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 45842@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 45842: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=45842
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
>

Comments

Greg Hogan March 11, 2021, 9:16 p.m. UTC | #1
A second patch from an unreleased upstream commit, which for me is
necessary to build the first patch off Guix master.

On Mon, Feb 1, 2021 at 9:14 AM Greg Hogan <code@greghogan.com> wrote:

> Another version bump.
>
> From 4153f16143405a4439cabe8c13f3b75440e1f1cc Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Mon, 1 Feb 2021 14:01:11 +0000
> Subject: [PATCH] gnu: abseil-cpp: Update to 20200923.3.
>
> * gnu/packages/cpp.scm (abseil-cpp): Update to 20200923.3.
> [arguments]: Enable external googletest.
> * gnu/packages/patches/abseil-cpp-fix.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Register it.
> ---
>  gnu/local.mk                              |  1 +
>  gnu/packages/cpp.scm                      |  7 +++++--
>  gnu/packages/patches/abseil-cpp-fix.patch | 16 ++++++++++++++++
>  3 files changed, 22 insertions(+), 2 deletions(-)
>  create mode 100644 gnu/packages/patches/abseil-cpp-fix.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index e93425f394..0dba1b5855 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -783,6 +783,7 @@ dist_patch_DATA = \
>    %D%/packages/patches/abcl-fix-build-xml.patch \
>    %D%/packages/patches/ableton-link-system-libraries-debian.patch \
>    %D%/packages/patches/abiword-explictly-cast-bools.patch \
> +  %D%/packages/patches/abseil-cpp-fix.patch \
>    %D%/packages/patches/adb-add-libraries.patch \
>    %D%/packages/patches/aegis-constness-error.patch         \
>    %D%/packages/patches/aegis-perl-tempdir1.patch           \
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index ae47490755..438713c38a 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -672,7 +672,7 @@ point and then, after each tween step, plugging back
> the result.")
>  (define-public abseil-cpp
>    (package
>      (name "abseil-cpp")
> -    (version "20200225.2")
> +    (version "20200923.3")
>      (source (origin
>                (method git-fetch)
>                (uri (git-reference
> @@ -681,11 +681,14 @@ point and then, after each tween step, plugging back
> the result.")
>                (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -                "0dwxg54pv6ihphbia0iw65r64whd7v8nm4wwhcz219642cgpv54y"))))
> +                "1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
> +              ;; Remove after next googletest release and update.
> +              (patches (search-patches "abseil-cpp-fix.patch"))))
>      (build-system cmake-build-system)
>      (arguments
>       `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
>                                 "-DABSL_RUN_TESTS=ON"
> +                               "-DABSL_USE_EXTERNAL_GOOGLETEST=ON"
>                                 ;; Needed, else we get errors like:
>                                 ;;
>                                 ;; ld:
> CMakeFiles/absl_periodic_sampler_test.dir/internal/periodic_sampler_test.cc.o:
> diff --git a/gnu/packages/patches/abseil-cpp-fix.patch
> b/gnu/packages/patches/abseil-cpp-fix.patch
> new file mode 100644
> index 0000000000..38971448f3
> --- /dev/null
> +++ b/gnu/packages/patches/abseil-cpp-fix.patch
> @@ -0,0 +1,16 @@
> +The GTEST_ALLOW_UNINSTANTIATED_PARAMTERIZED_TEST macro was added to
> googletest
> +in commit 0b024bd9 on master. It has been used in an abseil-cpp release
> before
> +a googletest release.
> +
> +--- a/absl/container/internal/unordered_map_modifiers_test.h
> ++++ b/absl/container/internal/unordered_map_modifiers_test.h
> +@@ -286,7 +286,9 @@ class UniquePtrModifiersTest : public ::testing::Test
> {
> +   }
> + };
> +
> ++#ifdef GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST
> + GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
> ++#endif
> +
> + TYPED_TEST_SUITE_P(UniquePtrModifiersTest);
> +
> --
> 2.30.0
>
> On Wed, Jan 13, 2021 at 10:13 AM GNU bug Tracking System <
> help-debbugs@gnu.org> wrote:
>
>> Thank you for filing a new bug report with debbugs.gnu.org.
>>
>> This is an automatically generated reply to let you know your message
>> has been received.
>>
>> Your message is being forwarded to the package maintainers and other
>> interested parties for their attention; they will reply in due course.
>>
>> Your message has been sent to the package maintainer(s):
>>  guix-patches@gnu.org
>>
>> If you wish to submit further information on this problem, please
>> send it to 45842@debbugs.gnu.org.
>>
>> Please do not send mail to help-debbugs@gnu.org unless you wish
>> to report a problem with the Bug-tracking system.
>>
>> --
>> 45842: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=45842
>> GNU Bug Tracking System
>> Contact help-debbugs@gnu.org with problems
>>
>
Ludovic Courtès March 22, 2021, 5:06 p.m. UTC | #2
Hi Greg,

Greg Hogan <code@greghogan.com> skribis:

> From 9d0a4d0d680ff116ca910ef5654690e12aa42ab2 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Mon, 1 Feb 2021 14:01:11 +0000
> Subject: [PATCH 1/2] gnu: abseil-cpp: Update to 20200923.3.
>
> * gnu/packages/cpp.scm (abseil-cpp): Update to 20200923.3.
> [arguments]: Enable external googletest.
> * gnu/packages/patches/abseil-cpp-fix.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Register it.

[...]

> From 9dee38402923238b77a0e9010eb0380849b840ae Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Thu, 11 Mar 2021 20:53:15 +0000
> Subject: [PATCH 2/2] gnu: abseil-cpp: Patch sterror_test.
>
> * gnu/packages/patches/abseil-cpp-fix-gtest.patch: Renamed file.
> * gnu/packages/patches/abseil-cpp-fix-strerror_test.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Rename / add files.
> * gnu/packages/cpp.scm (abseil-cpp)[source]: Use files.

Applied both, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index e93425f394..0dba1b5855 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -783,6 +783,7 @@  dist_patch_DATA = \
   %D%/packages/patches/abcl-fix-build-xml.patch \
   %D%/packages/patches/ableton-link-system-libraries-debian.patch \
   %D%/packages/patches/abiword-explictly-cast-bools.patch \
+  %D%/packages/patches/abseil-cpp-fix.patch \
   %D%/packages/patches/adb-add-libraries.patch \
   %D%/packages/patches/aegis-constness-error.patch         \
   %D%/packages/patches/aegis-perl-tempdir1.patch           \
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ae47490755..438713c38a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -672,7 +672,7 @@  point and then, after each tween step, plugging back
the result.")
 (define-public abseil-cpp
   (package
     (name "abseil-cpp")
-    (version "20200225.2")
+    (version "20200923.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -681,11 +681,14 @@  point and then, after each tween step, plugging back
the result.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0dwxg54pv6ihphbia0iw65r64whd7v8nm4wwhcz219642cgpv54y"))))
+                "1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
+              ;; Remove after next googletest release and update.
+              (patches (search-patches "abseil-cpp-fix.patch"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
                                "-DABSL_RUN_TESTS=ON"
+                               "-DABSL_USE_EXTERNAL_GOOGLETEST=ON"
                                ;; Needed, else we get errors like:
                                ;;
                                ;; ld:
CMakeFiles/absl_periodic_sampler_test.dir/internal/periodic_sampler_test.cc.o:
diff --git a/gnu/packages/patches/abseil-cpp-fix.patch
b/gnu/packages/patches/abseil-cpp-fix.patch
new file mode 100644
index 0000000000..38971448f3
--- /dev/null
+++ b/gnu/packages/patches/abseil-cpp-fix.patch
@@ -0,0 +1,16 @@ 
+The GTEST_ALLOW_UNINSTANTIATED_PARAMTERIZED_TEST macro was added to
googletest
+in commit 0b024bd9 on master. It has been used in an abseil-cpp release
before
+a googletest release.
+
+--- a/absl/container/internal/unordered_map_modifiers_test.h
++++ b/absl/container/internal/unordered_map_modifiers_test.h
+@@ -286,7 +286,9 @@ class UniquePtrModifiersTest : public ::testing::Test {
+   }
+ };
+
++#ifdef GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST
+ GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
++#endif
+