diff mbox series

[bug#48546,core-updates] gnu: boost: Update to 1.76.0.

Message ID CA+3U0Z=w_8OTyvocFz3-xs1mtJHe9jA4RPTxr6eK3qVreYhVSA@mail.gmail.com
State Accepted
Headers show
Series [bug#48546,core-updates] gnu: boost: Update to 1.76.0. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan May 20, 2021, 6:59 p.m. UTC
From 9cd911d33aa6a13b2c04f9bc0a9568fe0e19031a Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 29 Apr 2021 10:45:49 +0000
Subject: [PATCH] gnu: boost: Update to 1.76.0.

* gnu/packages/boost.scm (boost): Update to 1.76.0.
[source]: Remove upstreamed patch.
* gnu/packages/patches/boost-fix-static-linking.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
---
 gnu/local.mk                                     |  1 -
 gnu/packages/boost.scm                           |  6 ++----
 .../patches/boost-fix-transitive-linking.patch   | 16 ----------------
 3 files changed, 2 insertions(+), 21 deletions(-)
 delete mode 100644 gnu/packages/patches/boost-fix-transitive-linking.patch

-         print.text
-

Comments

Marius Bakke May 23, 2021, 2:06 p.m. UTC | #1
Hi!

Greg Hogan <code@greghogan.com> skriver:

>>From 9cd911d33aa6a13b2c04f9bc0a9568fe0e19031a Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Thu, 29 Apr 2021 10:45:49 +0000
> Subject: [PATCH] gnu: boost: Update to 1.76.0.
>
> * gnu/packages/boost.scm (boost): Update to 1.76.0.
> [source]: Remove upstreamed patch.
> * gnu/packages/patches/boost-fix-static-linking.patch: Delete file.
> * gnu/local.mk (dist_patch_DATA): Remove it.

I pushed a similar patch in b08d989045450c72260e3781ef458555b9e2597c
before seeing this.  Sorry for the duplicate work.  :-/

Thanks,
Marius
diff mbox series

Patch

From 9cd911d33aa6a13b2c04f9bc0a9568fe0e19031a Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 29 Apr 2021 10:45:49 +0000
Subject: [PATCH] gnu: boost: Update to 1.76.0.

* gnu/packages/boost.scm (boost): Update to 1.76.0.
[source]: Remove upstreamed patch.
* gnu/packages/patches/boost-fix-static-linking.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
---
 gnu/local.mk                                     |  1 -
 gnu/packages/boost.scm                           |  6 ++----
 .../patches/boost-fix-transitive-linking.patch   | 16 ----------------
 3 files changed, 2 insertions(+), 21 deletions(-)
 delete mode 100644 gnu/packages/patches/boost-fix-transitive-linking.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index add01cf6d2..4c7ce2815f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -878,7 +878,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/blender-2.79-oiio2.patch			\
   %D%/packages/patches/blender-2.79-python-3.7-fix.patch	\
   %D%/packages/patches/blender-2.79-python-3.8-fix.patch	\
-  %D%/packages/patches/boost-fix-transitive-linking.patch	\
   %D%/packages/patches/bpftrace-disable-bfd-disasm.patch	\
   %D%/packages/patches/byobu-writable-status.patch		\
   %D%/packages/patches/cairo-CVE-2018-19876.patch		\
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index c6cf452f09..e9da56e115 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -66,17 +66,15 @@ 
 (define-public boost
   (package
     (name "boost")
-    (version "1.75.0")
+    (version "1.76.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
                                   version "/source/boost_"
                                   (version-with-underscores version) ".tar.bz2"))
-              ; Should be included in next Boost update
-              (patches (search-patches "boost-fix-transitive-linking.patch"))
               (sha256
                (base32
-                "1js9zpij58l60kx46s3lxdp5207igppjnhqigwhbpdvd04gb6gcm"))))
+                "0hcc661savk32hx65997p0ss1awj6ala4cmz4w7lbi42x6k7nfgh"))))
     (build-system gnu-build-system)
     (inputs `(("icu4c" ,icu4c)
               ("zlib" ,zlib)))
diff --git a/gnu/packages/patches/boost-fix-transitive-linking.patch b/gnu/packages/patches/boost-fix-transitive-linking.patch
deleted file mode 100644
index a42feab109..0000000000
--- a/gnu/packages/patches/boost-fix-transitive-linking.patch
+++ /dev/null
@@ -1,16 +0,0 @@ 
-Patch from https://github.com/boostorg/boost_install/issues/47
-which should be included in the Boost 1.76 release.
-
-This patch prevents CMake from explicitly linking against Boost dependencies
-when building against the shared Boost libraries.
---- a/tools/boost_install/boost-install.jam
-+++ b/tools/boost_install/boost-install.jam
-@@ -483,7 +483,7 @@ rule generate-cmake-variant- ( target : sources * : properties * )
- 
-     .info "  deps3=" $(deps3) ;
- 
--    if $(deps3)
-+    if $(deps3) && $(link) = static
-     {
-         print.text
- 
-- 
2.31.1