diff mbox

[bug#55168,0/15] Fix aws-lc checksum and use with aws-sdk-cpp.

Message ID CA+3U0Z=QZj72ArCOijRh2EGB2qf-iFhpBj-q=BkP9954eR5-hw@mail.gmail.com
State Accepted
Headers show

Commit Message

Greg Hogan April 28, 2022, 3:59 p.m. UTC
I happened to notice the broken build for aws-lc when exploring the
dashboard at ci.guix.gnu.org. In my last patchset I had updated aws-lc to
the proper version but failed to update the checksum since it was not built
as a dependency of aws-sdk-cpp.

These patches replace openssl with aws-lc as the default dependency of s2n,
making aws-lc a transitive dependency of aws-sdk-cpp. I have tested with
the following builds:
  ./pre-inst-env guix build aws-sdk-cpp
  ./pre-inst-env guix build --with-input=aws-lc=libressl aws-sdk-cpp
  ./pre-inst-env guix build --with-input=aws-lc=openssl@1.1.1l aws-sdk-cpp

aws-c-common is now marked as supported only for i686-linux and
x86_64-linux, and s2n as supported only for x86_64-linux, as various tests
are failing or timing out on other systems.

Greg

Comments

Ludovic Courtès May 2, 2022, 12:46 p.m. UTC | #1
Hi,

Greg Hogan <code@greghogan.com> skribis:

> I happened to notice the broken build for aws-lc when exploring the
> dashboard at ci.guix.gnu.org. In my last patchset I had updated aws-lc to
> the proper version but failed to update the checksum since it was not built
> as a dependency of aws-sdk-cpp.

Oops, I plaid guilty as well, then.

> These patches replace openssl with aws-lc as the default dependency of s2n,
> making aws-lc a transitive dependency of aws-sdk-cpp. I have tested with
> the following builds:
>   ./pre-inst-env guix build aws-sdk-cpp
>   ./pre-inst-env guix build --with-input=aws-lc=libressl aws-sdk-cpp
>   ./pre-inst-env guix build --with-input=aws-lc=openssl@1.1.1l aws-sdk-cpp
>
> aws-c-common is now marked as supported only for i686-linux and
> x86_64-linux, and s2n as supported only for x86_64-linux, as various tests
> are failing or timing out on other systems.

Alright.  Applied the whole series, thanks!

Ludo’.
diff mbox

Patch

From ba8787cbad254edb933bd40d2d23a0175921555c Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Fri, 22 Apr 2022 17:28:17 +0000
Subject: [PATCH 14/15] gnu: s2n: Link to aws-lc as libcrypto dependency.

* gnu/packages/tls.scm (s2n):
[arguments]: Fix for openssl as replacement input for aws-lc.
[propagated-inputs]: Add aws-lc and remove openssl.
[supported-systems]: Only support x86_64-linux.
---
 gnu/packages/tls.scm | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 54921fdc86..84ed0caa5d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1130,7 +1130,7 @@  (define-public go-github-com-certifi-gocertifi
 (define-public s2n
   (package
     (name "s2n")
-    ; Update only when updating aws-crt-cpp.
+    ;; Update only when updating aws-crt-cpp.
     (version "1.3.10")
     (source (origin
               (method git-fetch)
@@ -1144,10 +1144,13 @@  (define-public s2n
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags
-       '("-DBUILD_SHARED_LIBS=ON")))
-    (propagated-inputs
-     `(("openssl" ,openssl)
-       ("openssl:static" ,openssl "static")))
+       '("-DBUILD_SHARED_LIBS=ON"
+         ;; Remove in next update; see https://github.com/aws/s2n-tls/pull/3108
+         ;; Building with 'Werror' results in compilation error (even building
+         ;; with gcc) when replacing the aws-lc input with openssl.
+         "-DUNSAFE_TREAT_WARNINGS_AS_ERRORS=OFF")))
+    (propagated-inputs (list aws-lc))
+    (supported-systems '("x86_64-linux"))
     (synopsis "SSL/TLS implementation in C99")
     (description
      "This library provides a C99 implementation of SSL/TLS.  It is designed to
-- 
2.36.0