From ba8787cbad254edb933bd40d2d23a0175921555c Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Fri, 22 Apr 2022 17:28:17 +0000
Subject: [PATCH 14/15] gnu: s2n: Link to aws-lc as libcrypto dependency.
* gnu/packages/tls.scm (s2n):
[arguments]: Fix for openssl as replacement input for aws-lc.
[propagated-inputs]: Add aws-lc and remove openssl.
[supported-systems]: Only support x86_64-linux.
---
gnu/packages/tls.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)
@@ -1130,7 +1130,7 @@ (define-public go-github-com-certifi-gocertifi
(define-public s2n
(package
(name "s2n")
- ; Update only when updating aws-crt-cpp.
+ ;; Update only when updating aws-crt-cpp.
(version "1.3.10")
(source (origin
(method git-fetch)
@@ -1144,10 +1144,13 @@ (define-public s2n
(build-system cmake-build-system)
(arguments
'(#:configure-flags
- '("-DBUILD_SHARED_LIBS=ON")))
- (propagated-inputs
- `(("openssl" ,openssl)
- ("openssl:static" ,openssl "static")))
+ '("-DBUILD_SHARED_LIBS=ON"
+ ;; Remove in next update; see https://github.com/aws/s2n-tls/pull/3108
+ ;; Building with 'Werror' results in compilation error (even building
+ ;; with gcc) when replacing the aws-lc input with openssl.
+ "-DUNSAFE_TREAT_WARNINGS_AS_ERRORS=OFF")))
+ (propagated-inputs (list aws-lc))
+ (supported-systems '("x86_64-linux"))
(synopsis "SSL/TLS implementation in C99")
(description
"This library provides a C99 implementation of SSL/TLS. It is designed to
--
2.36.0