diff mbox series

[bug#52920] gnu: Add python-pystitcher.

Message ID CA+3U0Z=M_5njK0bD03BeY_w4BGAp4tqFFQgbHN04qOpKu4wDsw@mail.gmail.com
State Accepted
Headers show
Series [bug#52920] gnu: Add python-pystitcher. | expand

Commit Message

Greg Hogan Dec. 31, 2021, 6:21 p.m. UTC
From 79411499a651687bf8ccb11662779056680a061b Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Fri, 31 Dec 2021 18:07:51 +0000
Subject: [PATCH 1/3] gnu: python-validators: Update to 0.18.2.

* gnu/packages/python-xyz.scm (python-validators): Update to 0.18.2.
---
 gnu/packages/python-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

customizable
+bookmarks using a declarative input in the form of a markdown file.")
+  (license license:expat)))

Comments

Nicolas Goaziou Jan. 11, 2022, 10:05 a.m. UTC | #1
Hello,

Greg Hogan <code@greghogan.com> writes:

> From 79411499a651687bf8ccb11662779056680a061b Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Fri, 31 Dec 2021 18:07:51 +0000
> Subject: [PATCH 1/3] gnu: python-validators: Update to 0.18.2.
>
> * gnu/packages/python-xyz.scm (python-validators): Update to 0.18.2.

[...]

>
> * gnu/packages/python-xyz.scm (python-pypdf3): New variable.

[...]

> * gnu/packages/python-xyz.scm (python-pystitcher): New variable.

I fixed description of this one.

Also, I had to deal with merge conflicts because you added your packages
at the end of the python-xyz.scm file and I wasn't quick enough to apply
your patches. In large files such as python-xyz.scm, I suggest not to
put definitions there.

Anyway, all applied. Thanks!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b6534c677f..b4ed17cca9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19111,13 +19111,13 @@  (define-public python-shellescape
 (define-public python-validators
   (package
     (name "python-validators")
-    (version "0.14.2")
+    (version "0.18.2")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "validators" version))
               (sha256
                (base32
-                "024m15j33szd0v8k5l4ccish6n0b4knq81gmb4fq25ynwyyyd4mi"))))
+                "19lypf7hm7p203ay3v8zmckc5rv6889zkfdm16nki1972f99mk9p"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
-- 
2.34.0

From 7f4633525ba6676f90ff29dca871fa76823da871 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Fri, 31 Dec 2021 18:09:32 +0000
Subject: [PATCH 2/3] gnu: Add python-pypdf3.

* gnu/packages/python-xyz.scm (python-pypdf3): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b4ed17cca9..07c587792c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27867,3 +27867,24 @@  (define-public python-iwlib
     (description
      "This package provides a Python interface to iw wireless tools.")
     (license license:gpl2)))
+
+(define-public python-pypdf3
+  (package
+    (name "python-pypdf3")
+    (version "1.0.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "PyPDF3" version))
+        (sha256
+          (base32
"018hlq9q2qa96vw4j7ppq352znykldwy98h2w9qcpkvpi93sjqhc"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-tqdm))
+  (home-page "https://github.com/sfneal/PyPDF3")
+  (synopsis "Utility to read and write PDFs with Python")
+  (description "PyPDF3 is a pure-python PDF library capable of splitting,
+merging together, cropping, and transforming the pages of PDF files.  It
can
+also add custom data, viewing options, and passwords to PDF files.  It can
+retrieve text and metadata from PDFs as well as merge entire files
together.")
+  (license license:bsd-3)))
-- 
2.34.0

From c004ab43c203f6bfc90fb7b4e0e5873293cfebd0 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Fri, 31 Dec 2021 18:12:07 +0000
Subject: [PATCH 3/3] gnu: Add python-pystitcher.

* gnu/packages/python-xyz.scm (python-pystitcher): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07c587792c..41b4230b49 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27888,3 +27888,29 @@  (define-public python-pypdf3
 also add custom data, viewing options, and passwords to PDF files.  It can
 retrieve text and metadata from PDFs as well as merge entire files
together.")
   (license license:bsd-3)))
+
+(define-public python-pystitcher
+  (package
+    (name "python-pystitcher")
+    (version "1.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/captn3m0/pystitcher")
+         (commit
+          (string-append "v" version))))
+       (file-name
+        (git-file-name name version))
+       (sha256
+        (base32 "03yrzqhcsjdj5zprrk3bh5bbyqfy3vfhxra9974vmkir3m121394"))))
+    (build-system python-build-system)
+    (inputs
+     (list python-html5lib python-importlib-metadata python-markdown
+           python-pypdf3 python-validators))
+  (home-page "https://github.com/captn3m0/pystitcher")
+  (synopsis "Declaratively stitch together a PDF file from multiple
sources")
+  (description "Stitch your PDF files together, generating nice