diff mbox series

[bug#45593] gnu: git: Update to 2.30.0.

Message ID CA+3U0Z=9qtyNpu-rDRj1eVRhFAY3H7bYiUALQu0+u-ZzXjPMKA@mail.gmail.com
State Accepted
Headers show
Series [bug#45593] gnu: git: Update to 2.30.0. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Jan. 1, 2021, 12:39 p.m. UTC
From 426a35322d0b4037d26802584847b71cb44484e4 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Fri, 1 Jan 2021 12:37:46 +0000
Subject: [PATCH] gnu: git: Update to 2.30.0.

* gnu/packages/version-control.scm (git): Update to 2.30.0.
---
 gnu/packages/version-control.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Leo Famulari Jan. 1, 2021, 10:13 p.m. UTC | #1
On Fri, Jan 01, 2021 at 07:39:36AM -0500, Greg Hogan wrote:
> From 426a35322d0b4037d26802584847b71cb44484e4 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Fri, 1 Jan 2021 12:37:46 +0000
> Subject: [PATCH] gnu: git: Update to 2.30.0.
> 
> * gnu/packages/version-control.scm (git): Update to 2.30.0.

Thanks! Pushed as ce3b439ae7c6dcc1f0cc334fa1c6a783854ec761
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm
b/gnu/packages/version-control.scm
index d20cf7e655..b57b0320b0 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -32,6 +32,7 @@ 
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -163,14 +164,14 @@  as well as the classic centralized workflow.")
 (define-public git
   (package
    (name "git")
-   (version "2.29.2")
+   (version "2.30.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://kernel.org/software/scm/git/git-"
                                 version ".tar.xz"))
             (sha256
              (base32
-              "1h87yv117ypnc0yi86941089c14n91gixk8b6shj2y35prp47z7j"))))
+              "06ad6dylgla34k9am7d5z8y3rryc8ln3ibq5z0d74rcm20hm0wsm"))))
    (build-system gnu-build-system)
    (native-inputs
     `(("native-perl" ,perl)
@@ -187,7 +188,7 @@  as well as the classic centralized workflow.")
                 version ".tar.xz"))
           (sha256
            (base32
-            "14npkg9rnp2yclsx5p622qpm6byzfy5k5wb209vkmm5r60m4mm72"))))
+            "0xngjg60rwzrb9x32d1qbdd8szkzwcyha5qni7ilkldxsl2q8avv"))))
       ;; For subtree documentation.
       ("asciidoc" ,asciidoc-py3)
       ("docbook-xsl" ,docbook-xsl)