diff mbox series

[bug#54955] gnu: ccache: Update to 4.6.

Message ID CA+3U0Z=9BTJ8wpEYv-wVtqyVavCy4uaNUFJKv6xPWg+EPf9Z3A@mail.gmail.com
State Accepted
Headers show
Series [bug#54955] gnu: ccache: Update to 4.6. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan April 15, 2022, 2:52 p.m. UTC
$ ./pre-inst-env guix refresh -l ccache
No dependents other than itself: ccache@4.6


From 22fd8e1e67d3795ce635ab370f2fbbcfdfa985e4 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Tue, 12 Apr 2022 19:36:39 +0000
Subject: [PATCH] gnu: ccache: Update to 4.6.

* gnu/packages/ccache.scm (ccache): Update to 4.6.
---
 gnu/packages/ccache.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

                          (@ (gnu packages base) which)))

Comments

Efraim Flashner April 17, 2022, 3:45 p.m. UTC | #1
Everything looks good on aarch64. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index 2923a998c8..d359e30f81 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -2,7 +2,7 @@ 
 ;;; Copyright © 2014, 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,14 +32,14 @@  (define-module (gnu packages ccache)
 (define-public ccache
   (package
     (name "ccache")
-    (version "4.5.1")
+    (version "4.6")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "
https://github.com/ccache/ccache/releases/download/v"
                            version "/ccache-" version ".tar.xz"))
        (sha256
-        (base32 "05wmflxdc8h3d00gr3kilr5dmrqxj6lcmq9ic575ydi60fz6w62i"))))
+        (base32 "1sa576ff8hc1swq55mdfp5gsnpys276gf37n83k6k49myihbharx"))))
     (build-system cmake-build-system)
     (native-inputs (list perl ; for test/run