diff mbox series

[bug#43425] gnu: openblas: Update to 0.3.10.

Message ID CA+3U0Z=93-Lb3xVc5PVEvwVb+coqK+bEE4130F0UG5Kgf9OV3Q@mail.gmail.com
State Accepted
Headers show
Series [bug#43425] gnu: openblas: Update to 0.3.10. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Greg Hogan Sept. 15, 2020, 1:59 p.m. UTC
From 3b23f2a61b0a5b25389875441739a53bfe5d9aab Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Mon, 14 Sep 2020 15:52:50 +0000
Subject: [PATCH] gnu: openblas: Update to 0.3.10.

* gnu/packages/maths.scm (openblas): Update to 0.3.10 and fetch from github.
---
 gnu/packages/maths.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

      `(#:test-target "test"

Comments

Mathieu Othacehe Sept. 17, 2020, 1:58 p.m. UTC | #1
Hello Greg,

> * gnu/packages/maths.scm (openblas): Update to 0.3.10 and fetch from github.

We prefer not to use the github archives that can be
regenerated. If it is really necessary to switch to github then you can
use the "git-fetch" method.

Could you please send an updated patch?

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index df4d39f900..6a1d772318 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3609,16 +3609,16 @@  parts of it.")
 (define-public openblas
   (package
     (name "openblas")
-    (version "0.3.9")
+    (version "0.3.10")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://sourceforge/openblas/v" version
"/OpenBLAS%20"
-                           version "%20version.tar.gz"))
+       (uri (string-append "https://github.com/xianyi/OpenBLAS/archive/v"
+                           version ".tar.gz"))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "14iz9xnrb9xiwgj84j94mc74gg0zn2vsy9fmsijxxma1n7dck4w3"))))
+         "14qndvg229w2jh2di6n7d8kvw343yafsmv1fzx0qd6vyz1sx5104"))))
     (build-system gnu-build-system)
     (arguments