diff mbox series

[bug#43474] gnu: python-3.8: Update to 3.8.5.

Message ID CA+3U0Z=1zdkVBqmK0eu=bp9Xk4Lgv=aNNigcR1_9=-sa8W9Hyw@mail.gmail.com
State Accepted
Headers show
Series [bug#43474] gnu: python-3.8: Update to 3.8.5. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Greg Hogan Sept. 17, 2020, 5:25 p.m. UTC
From b3a64ef4a352bc12a5ca7b98caa2f775f04fa342 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 17 Sep 2020 17:18:52 +0000
Subject: [PATCH] gnu: python-3.8: Update to 3.8.5.

* gnu/packages/python.scm (python-3.8): Update to 3.8.5.
---
 gnu/packages/python.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Sept. 18, 2020, 6:59 p.m. UTC | #1
On Thu, Sep 17, 2020 at 01:25:48PM -0400, Greg Hogan wrote:
> From b3a64ef4a352bc12a5ca7b98caa2f775f04fa342 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Thu, 17 Sep 2020 17:18:52 +0000
> Subject: [PATCH] gnu: python-3.8: Update to 3.8.5.
> 
> * gnu/packages/python.scm (python-3.8): Update to 3.8.5.

Thanks!

Python is a package with a large number of dependents:

$ guix refresh -l python@3
Building the following 4230 packages would ensure 10496 dependent packages are rebuilt:
[...]

Packages like this go on the core-updates branch, which is for "major
and potentially disruptive changes", including changes that will cause
more than 1200 rebuilds per CPU architecture [0].

So, I've pushed this patch to the core-updates branch as commit
8944f1a4a4bfe65ad83d4926fbdbeb3e11ec7728 [1] and it should be be made
available to Guix users at some point in the next few months.

[0] https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html

[1] https://git.savannah.gnu.org/cgit/guix.git/commit/?h=core-updates&id=8944f1a4a4bfe65ad83d4926fbdbeb3e11ec7728
diff mbox series

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 993ca0b40f..897d9ba7cf 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -364,7 +364,7 @@  data types.")
 (define-public python-3.8
   (package (inherit python-2)
     (name "python")
-    (version "3.8.2")
+    (version "3.8.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.python.org/ftp/python/"
@@ -376,7 +376,7 @@  data types.")
                         "python-3-search-paths.patch"))
               (sha256
                (base32
-                "1ps5v323cp5czfshqjmbsqw7nvrdpcbk06f62jbzaqik4gfffii6"))
+                "1c43dbv9lvlp3ynqmgdi4rh8q94swanhqarqrdx62zmigpakw073"))
               (modules '((guix build utils)))
               (snippet
                '(begin