diff mbox series

[bug#38625] Fwd: [bug#38625] [PATCH] music.scm: Add glyr

Message ID CA+2hkpXEWmafo+aYjX2TvdW0iqkqRV8zXRU8Yn2GCPa3PrBZng@mail.gmail.com
State Accepted
Headers show
Series [bug#38625] Fwd: [bug#38625] [PATCH] music.scm: Add glyr | expand

Commit Message

Riku Viitanen Dec. 18, 2019, 4:57 p.m. UTC
Hi Ricardo, and thanks for the feedback!

I think all the mentioned issues should now be fixed.
I checked some of the source files, and it turns out they say permit any
later version of the license, so I changed the license to lgpl3+.
Only the README file mentions "just" LGPLv3 without saying anything about
later versions, so I thought it meant the same as "only".

Here's the new patch in git format:

From 97d4d5d7d16eb87896d81e070510d919118aa622 Mon Sep 17 00:00:00 2001
From: Riku Viitanen <riku.viitanen0@gmail.com>
Date: Wed, 18 Dec 2019 18:30:14 +0200
Subject: [PATCH] gnu: Add glyr

* gnu/packages/music.scm (glyr): New variable
---
 gnu/packages/music.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

+library for a musicplayer, but has been extended to work as a standalone
+program which is able to download cover art, lyrics, photos, biographies,
+reviews and more.")
+    (license license:lgpl3+)))

Comments

Christopher Baines Nov. 19, 2020, 9:27 a.m. UTC | #1
Riku Viitanen <riku.viitanen0@gmail.com> writes:

> Hi Ricardo, and thanks for the feedback!
>
> I think all the mentioned issues should now be fixed.
> I checked some of the source files, and it turns out they say permit any
> later version of the license, so I changed the license to lgpl3+.
> Only the README file mentions "just" LGPLv3 without saying anything about
> later versions, so I thought it meant the same as "only".

Hi Riku,

Apologies for the delay in following up on this.

I've gone ahead and pushed the package definition to master as
aee183e1a57aa7606c79d9375e8e3f13e7726e41. I made some tweaks which I'll
describe below.

Also, I couldn't figure out how to apply the patch you included. Because
of things like email clients wrapping lines, the best approach for
sending patches is "git send-email", and if that isn't an option,
attaching the patch files to an email is the next best option.

> Here's the new patch in git format:
>
> From 97d4d5d7d16eb87896d81e070510d919118aa622 Mon Sep 17 00:00:00 2001
> From: Riku Viitanen <riku.viitanen0@gmail.com>
> Date: Wed, 18 Dec 2019 18:30:14 +0200
> Subject: [PATCH] gnu: Add glyr
>
> * gnu/packages/music.scm (glyr): New variable
> ---
>  gnu/packages/music.scm | 35 +++++++++++++++++++++++++++++++++++
>  1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index f80fb067e8..0adfa96fbe 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -25,6 +25,7 @@
>  ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
>  ;;; Copyright © 2019 David Wilson <david@daviwil.com>
>  ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
> +;;; Copyright © 2019 Riku Viitanen <riku.viitanen0@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -5106,3 +5107,37 @@ MIDI drums and comes as two separate drumkits: Black
> Pearl and Red Zeppelin.")
>      (description "Helm is a cross-platform polyphonic synthesizer
> available standalone
>  and as an LV2 plugin.")
>      (license license:gpl3+)))
> +
> +(define-public glyr
> +  (package
> +    (name "glyr")
> +    (version "1.0.10")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                     (url "https://github.com/sahib/glyr.git")
> +                     (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +                (base32
> +                 "1miwbqzkhg0v3zysrwh60pj9sv6ci4lzq2vq2hhc6pc6hdyh8xyr"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     '(#:tests? #f))

So I had a go at running the tests. Unfortunately some of them depend on
the network, so I was only able to run some of them. There's also Python
tests, but I think that requires packaging some additional Python
libraries, so I've just put a comment in about that.

> +    (inputs
> +     `(("glib" ,glib)
> +       ("curl" ,curl)
> +       ("sqlite" ,sqlite)))
> +    (native-inputs
> +     `(("pkg-config" ,pkg-config)))
> +    (home-page "https://github.com/sahib/glyr")
> +    (synopsis "Search engine for music related metadata")
> +    (description
> +     "Glyr comes both in a command-line interface tool (@command{glyrc})
> and
> +as a C library (libglyr), both with an easy to use interface. The sort of
> +metadata glyr is searching (and downloading) is usually the data you see in
> +your musicplayer. And indeed, originally it was written to serve as
> internally
> +library for a musicplayer, but has been extended to work as a standalone
> +program which is able to download cover art, lyrics, photos, biographies,
> +reviews and more.")
> +    (license license:lgpl3+)))

Thanks again for the patch,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f80fb067e8..0adfa96fbe 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2019 Riku Viitanen <riku.viitanen0@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5106,3 +5107,37 @@  MIDI drums and comes as two separate drumkits: Black
Pearl and Red Zeppelin.")
     (description "Helm is a cross-platform polyphonic synthesizer
available standalone
 and as an LV2 plugin.")
     (license license:gpl3+)))
+
+(define-public glyr
+  (package
+    (name "glyr")
+    (version "1.0.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sahib/glyr.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+                (base32
+                 "1miwbqzkhg0v3zysrwh60pj9sv6ci4lzq2vq2hhc6pc6hdyh8xyr"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f))
+    (inputs
+     `(("glib" ,glib)
+       ("curl" ,curl)
+       ("sqlite" ,sqlite)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/sahib/glyr")
+    (synopsis "Search engine for music related metadata")
+    (description
+     "Glyr comes both in a command-line interface tool (@command{glyrc})
and
+as a C library (libglyr), both with an easy to use interface. The sort of
+metadata glyr is searching (and downloading) is usually the data you see in
+your musicplayer. And indeed, originally it was written to serve as
internally