diff mbox series

[bug#44814,v2] gnu: Add oauth2l.

Message ID C38NK8s6W4fHgtz8Cq2kYj_GZ2xKkVS7FS4Jn0fmBAzNGxjHZDIHPTByE4KSaSqTreR7vX9IOy2qtRGoNjyrMPJLTQEvpTAHy0WGjNXd5PE=@protonmail.com
State Accepted
Headers show
Series [bug#44814,v2] gnu: Add oauth2l. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 3, 2021, 12:14 p.m. UTC
Here's updated version of the patch. Otherwise LGTM.

* gnu/packages/authentication.scm (oauth2l): New variable.

--8<---------------cut here---------------start------------->8---
--
2.33.1

Comments

Nicolas Goaziou Jan. 14, 2022, 8:39 p.m. UTC | #1
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/authentication.scm (oauth2l): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/authentication.scm b/gnu/packages/authentication.scm
index a8070f4789..487b7171b1 100644
--- a/gnu/packages/authentication.scm
+++ b/gnu/packages/authentication.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,6 +28,7 @@  (define-module (gnu packages authentication)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages xml)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system go)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
@@ -91,6 +93,32 @@  (define-public oath-toolkit
     (license (list license:lgpl2.1+     ; the libraries (liboath/ & libpskc/)
                    license:gpl3+))))    ; the tools (everything else)

+(define-public oauth2l
+  (package
+    (name "oauth2l")
+    (version "1.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/google/oauth2l")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0a9x0b31ybyjg0k7923xw6zr6crm0kigcn8g6hyr228nbvw35r8w"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/google/oauth2l"))
+    (home-page "https://github.com/google/oauth2l")
+    (synopsis "Simple CLI for interacting with Google API authentication")
+    (description
+     "@code{oauth2l} (pronounced ``oauth tool'') is a simple command-line tool
+for working with @url{https://developers.google.com/identity/protocols/OAuth2,
+Google OAuth 2.0} written in Go.  Its primary use is to fetch and print OAuth
+2.0 access tokens, which can be used with other command-line tools and
+scripts.")
+    (license license:asl2.0)))
+
 (define-public yubico-pam
   (let ((commit "b5bd00db81e0e0e0ecced65c684080bb56ddc35b")
         (revision "0"))