diff mbox series

[bug#56252] gnu: polkit-mozjs: Fix native-inputs usage.

Message ID B_CFQDy5KLheC3sodY7GB7qAP5KbxyAQ9KC1Icp3s5IGK9ILZ72PmklC8NpuD5vcsAvpDCCV3sYJpgnSJXhW1ew2g8ViwpX5pl1zom6itrk=@jeandudey.tech
State Accepted
Headers show
Series [bug#56252] gnu: polkit-mozjs: Fix native-inputs usage. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jean Pierre De Jesus DIAZ June 27, 2022, 10:34 a.m. UTC
This patch fixes cross-compilation for `polkit-mozjs' and `polkit-duktape'.

The error can be seen by executing:

guix build polkit-duktape \
           --target=aarch64-linux-gnu

—
Jean-Pierre De Jesus DIAZ

Comments

Liliana Marie Prikler June 27, 2022, 12:19 p.m. UTC | #1
Am Montag, dem 27.06.2022 um 10:34 +0000 schrieb Jean Pierre De Jesus
DIAZ:

> -           (lambda* (#:key inputs #:allow-other-keys)
> -             (let ((xsldoc (string-append (assoc-ref inputs
> "docbook-xsl")
> +           (lambda* (#:key native-inputs #:allow-other-keys)
> +             (let ((xsldoc (string-append (assoc-ref native-inputs
> "docbook-xsl")
The correct usage would be (or native-inputs inputs).

Cheers
diff mbox series

Patch

From ef8d6092de9a134cea73893536eb9ad9615454fe Mon Sep 17 00:00:00 2001
Message-Id: <ef8d6092de9a134cea73893536eb9ad9615454fe.1656325553.git.me@jeandudey.tech>
From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
Date: Mon, 27 Jun 2022 12:18:05 +0200
Subject: [PATCH] gnu: polkit-mozjs: Fix native-inputs on stage.

* gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of
  `inputs' to `native-inputs' when searching for `docbook-xsl' path as
  it is a native input.
---
 gnu/packages/polkit.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a75608cd43..8d9b6773c5 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -119,8 +120,8 @@  (define-public polkit-mozjs
                 (("@INTROSPECTION_TYPELIBDIR@")
                  (string-append out "/lib/girepository-1.0/"))))))
          (add-after 'unpack 'fix-manpage-generation
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((xsldoc (string-append (assoc-ref inputs "docbook-xsl")
+           (lambda* (#:key native-inputs #:allow-other-keys)
+             (let ((xsldoc (string-append (assoc-ref native-inputs "docbook-xsl")
                                           "/xml/xsl/docbook-xsl-"
                                           ,(package-version docbook-xsl))))
                (substitute* '("docs/man/Makefile.am" "docs/man/Makefile.in")
-- 
2.36.1