diff mbox series

[bug#51212,v3,2/2] gnu: Add wireplumber.

Message ID BYAPR05MB4023B50E80EC4F8A09AE62BEC58B9@BYAPR05MB4023.namprd05.prod.outlook.com
State Accepted
Headers show
Series [bug#51212,v3,1/2] gnu: pipewire-0.3: Update to 0.3.39. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith Nov. 2, 2021, 11:26 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/linux.scm (wireplumber): New variable.
---
 gnu/packages/linux.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Maxim Cournoyer June 24, 2022, 12:40 a.m. UTC | #1
Hi,

pipewire was updated by Tobias to 0.3.43 and wireplumber added by
Josselin and updated to 0.4.6 by Tobias.


I think we're covered :-).  Thanks for the contribution.

Closing.

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 48cfc70bc7..beac03eb72 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -132,6 +132,7 @@  (define-module (gnu packages linux)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages serialization)
   #:use-module (gnu packages slang)
+  #:use-module (gnu packages sphinx)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tls)
@@ -8074,6 +8075,38 @@  (define-public pipewire-0.3
                ("vulkan-loader" ,vulkan-loader)
                ("vulkan-headers" ,vulkan-headers))))))
 
+(define-public wireplumber
+  (package
+    (name "wireplumber")
+    (version "0.4.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/pipewire/wireplumber")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0vr84xlnwlhrfq9l13rxh8cb8s389wlyafvi6bah444acmpx1lwv"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:meson ,meson-next ;; Needs at least 0.56.0
+       #:configure-flags (list "-Dsystem-lua=true")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("glib-bin" ,glib "bin")))
+    (inputs
+     `(("dbus" ,dbus)
+       ("glib" ,glib)
+       ("lua" ,lua)
+       ("pipewire" ,pipewire-0.3)))
+    (home-page "https://pipewire.org/")
+    (synopsis "Modular session and policy manager for PipeWire")
+    (description "WirePlumber is a daemon that links streams from applications to their
+appropriate device.  For example WirePlumber could link an audio stream to a
+speaker.")
+    (license license:expat)))
+
 (define-public ell
   (package
     (name "ell")