diff mbox series

[bug#52439] gnu: emacs-recutils: Update to 1.8.2-0.058dbe4.

Message ID BYAPR05MB402343D6BA6C604D5DE1755CC5759@BYAPR05MB4023.namprd05.prod.outlook.com
State Accepted
Headers show
Series [bug#52439] gnu: emacs-recutils: Update to 1.8.2-0.058dbe4. | expand

Commit Message

Morgan Smith Dec. 14, 2021, 12:54 a.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/databases.scm (emacs-recutils): Update to 1.8.2-0.058dbe4.
[inherit]: Don't inherit from recutils
[source]: Add
[native-inputs]: Add texinfo
[home-page]: Add
[arguments]: Add make-info phase
[license]: Add
---

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> For the record, the convention is usually to use the upstream name,
> *but that's not always reasonable*.

I am very tempted to put rec-mode in the upstream-name package
properties but I feel like that is not at all what that property is
intended for.

Thanks for being open to a name change but I'm starting to feel like
maybe I'm just being stubborn and there would be very little benefit
:P.  Especially since you've raised some very good points.

Also thanks for reporting that bug! I had experienced it but didn't
bother to debug it :P

 gnu/packages/databases.scm | 49 +++++++++++++++++++++++++-------------
 1 file changed, 33 insertions(+), 16 deletions(-)

--
2.34.0

Comments

Liliana Marie Prikler Dec. 14, 2021, 7:36 p.m. UTC | #1
Hi,

Note, that you don't need to clean any of this up; I'll do it myself
before pushing.  However, due to the recent c-u-f merge and the fact
that I only have limited time per day to actually push things, I wanted
to give some feedback ahead of time for the sake of transparency.

Am Montag, den 13.12.2021, 19:54 -0500 schrieb
Morgan.J.Smith@outlook.com:
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
> 
> * gnu/packages/databases.scm (emacs-recutils): Update to 1.8.2-
> 0.058dbe4.
> [inherit]: Don't inherit from recutils
> [source]: Add
> [native-inputs]: Add texinfo
> [home-page]: Add
> [arguments]: Add make-info phase
> [license]: Add
> ---
Generally, we use full sentences here.
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> > For the record, the convention is usually to use the upstream name,
> > *but that's not always reasonable*.
> 
> I am very tempted to put rec-mode in the upstream-name package
> properties but I feel like that is not at all what that property is
> intended for.
You *can* actually use upstream-name if you use elpa as source.  That
would have the effect of making `guix refresh' work as intended.  

> Thanks for being open to a name change but I'm starting to feel like
> maybe I'm just being stubborn and there would be very little benefit
> :P.  Especially since you've raised some very good points.
Uhm, actually I'm just as stubborn in not wanting another deprecated-
package :P

>  gnu/packages/databases.scm | 49 +++++++++++++++++++++++++-----------
> --
>  1 file changed, 33 insertions(+), 16 deletions(-)
> 
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index 7cff0f99c5..c0b714fc37 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -141,6 +141,7 @@ (define-module (gnu packages databases)
>    #:use-module (gnu packages sqlite)
>    #:use-module (gnu packages tcl)
>    #:use-module (gnu packages terminals)
> +  #:use-module (gnu packages texinfo)
>    #:use-module (gnu packages textutils)
>    #:use-module (gnu packages time)
>    #:use-module (gnu packages tls)
> @@ -1384,24 +1385,40 @@ (define-public recutils
>      (home-page "https://www.gnu.org/software/recutils/")))
>  
>  (define-public emacs-recutils
> -  (package
> -    (inherit recutils)
> -    (name "emacs-recutils")
> -    (build-system emacs-build-system)
> -    (arguments
> -     '(#:phases
> -       (modify-phases %standard-phases
> -         (add-after 'unpack 'change-directory
> -           (lambda _
> -             (chdir "etc")
> -             #t)))))
> -    (native-inputs '())
> -    (inputs '())
> -    (synopsis "Emacs mode for working with recutils database files")
> -    (description "This package provides an Emacs major mode
> @code{rec-mode}
> +  ;; Untagged release
> +  (let ((commit "058dbe420e63bd460c0c8d09dd97ab55bc45533a")
> +        (revision "0"))
> +    (package
> +      (name "emacs-recutils")
> +      (version (git-version "1.8.2" revision commit))
Following the discussion over at rec-mode, it appears as though ELPA is
seen as some source of truth.  That is a bit disappointing to us
Guixers, given the lz vs. uncompressed archive thing ELPA has, but I
think we can point to ELPA here while ensuring that we also push this
to SWH.
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "
> https://git.savannah.gnu.org/git/recutils/rec-mode.git")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                  "1qy8wrj14nzxzr6zvs4574v54jlhqszm1ybgq4a8pavkx2ay4
> c7r"))
> +                (modules '((guix build utils)))
> +                (snippet '(begin (delete-file "rec-mode.info")))))
> +      (arguments
> +       '(#:phases
> +         (modify-phases %standard-phases
> +           (add-before 'install 'make-info
> +             (lambda _
> +               (invoke "makeinfo" "--no-split"
> +                       "-o" "rec-mode.info" "rec-mode.texi"))))))
> +      (native-inputs
> +       `(("texinfo" ,texinfo)))
> +      (build-system emacs-build-system)
It's always a good idea to put build-system before arguments.
> +      (home-page "https://www.gnu.org/software/recutils/")
> +      (synopsis "Emacs mode for working with recutils database
> files")
> +      (description "This package provides an Emacs major mode
> @code{rec-mode}
>  for working with GNU Recutils text-based, human-editable
> databases.  It
>  supports editing, navigation, and querying of recutils database
> files
> -including field and record folding.")))
> +including field and record folding.")
> +      (license license:gpl3+))))
Otherwise LGTM.  Again, I'll push this with adjustments to the above
soon™, but can't promise a fix date yet.

Cheers
Liliana Marie Prikler Dec. 14, 2021, 8:34 p.m. UTC | #2
Am Dienstag, den 14.12.2021, 20:36 +0100 schrieb Liliana Marie Prikler:
> Hi,
> 
> Note, that you don't need to clean any of this up; I'll do it myself
> before pushing.  However, due to the recent c-u-f merge and the fact
> that I only have limited time per day to actually push things, I
> wanted to give some feedback ahead of time for the sake of
> transparency.
Sorry for the noise, it seems my pull finished quicker than expected. 
I also followed up with the name change + deprecation, since handling
of upstream-name is not in the ELPA importer.

Thanks and enjoy Guix 1.4.0
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7cff0f99c5..c0b714fc37 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -141,6 +141,7 @@  (define-module (gnu packages databases)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages terminals)
+  #:use-module (gnu packages texinfo)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages time)
   #:use-module (gnu packages tls)
@@ -1384,24 +1385,40 @@  (define-public recutils
     (home-page "https://www.gnu.org/software/recutils/")))
 
 (define-public emacs-recutils
-  (package
-    (inherit recutils)
-    (name "emacs-recutils")
-    (build-system emacs-build-system)
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'change-directory
-           (lambda _
-             (chdir "etc")
-             #t)))))
-    (native-inputs '())
-    (inputs '())
-    (synopsis "Emacs mode for working with recutils database files")
-    (description "This package provides an Emacs major mode @code{rec-mode}
+  ;; Untagged release
+  (let ((commit "058dbe420e63bd460c0c8d09dd97ab55bc45533a")
+        (revision "0"))
+    (package
+      (name "emacs-recutils")
+      (version (git-version "1.8.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.savannah.gnu.org/git/recutils/rec-mode.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1qy8wrj14nzxzr6zvs4574v54jlhqszm1ybgq4a8pavkx2ay4c7r"))
+                (modules '((guix build utils)))
+                (snippet '(begin (delete-file "rec-mode.info")))))
+      (arguments
+       '(#:phases
+         (modify-phases %standard-phases
+           (add-before 'install 'make-info
+             (lambda _
+               (invoke "makeinfo" "--no-split"
+                       "-o" "rec-mode.info" "rec-mode.texi"))))))
+      (native-inputs
+       `(("texinfo" ,texinfo)))
+      (build-system emacs-build-system)
+      (home-page "https://www.gnu.org/software/recutils/")
+      (synopsis "Emacs mode for working with recutils database files")
+      (description "This package provides an Emacs major mode @code{rec-mode}
 for working with GNU Recutils text-based, human-editable databases.  It
 supports editing, navigation, and querying of recutils database files
-including field and record folding.")))
+including field and record folding.")
+      (license license:gpl3+))))
 
 (define-public rocksdb
   (package