diff mbox series

[bug#49336] gnu: shellcheck: Generate and install manpage

Message ID BYAPR05MB402334206C8065A5A7AF2BB6C51F9@BYAPR05MB4023.namprd05.prod.outlook.com
State Accepted
Headers show
Series [bug#49336] gnu: shellcheck: Generate and install manpage | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith July 2, 2021, 6:10 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/haskell-apps.scm (shellcheck)
[arguments]<#:phases>: Add build-manpage and install-manpage phases
[native-inputs]: Add pandoc
---
 gnu/packages/haskell-apps.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

Tobias Geerinckx-Rice July 2, 2021, 6:37 p.m. UTC | #1
Morgan,

Morgan.J.Smith@outlook.com 写道:
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/haskell-apps.scm (shellcheck)
> [arguments]<#:phases>: Add build-manpage and install-manpage 
> phases
> [native-inputs]: Add pandoc

Thanks!  I added full stops to some lines and pushed it.

> +             #t))
> +             #t)))))

I removed these as well to avoid future noise: the requirement is 
obsolete on core-updates, but unfortunately the warning can't be 
removed on master.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index af777d1e3a..59e044b424 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
 ;;; Copyright © 2021 EuAndreh <eu@euandre.org>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -857,11 +858,27 @@  too slow and you'll get wound up in the scroll and crushed.")
         (base32 "06m4wh891nah3y0br4wh3adpsb16zawkb2ijgf1vcz61fznj6ps1"))
        (file-name (string-append name "-" version ".tar.gz"))))
     (build-system haskell-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'build 'build-manpage
+           (lambda _
+             ;; Run script to generate manpage
+             (invoke "sh" "manpage")
+             #t))
+         (add-after 'install 'install-manpage
+           (lambda* (#:key outputs #:allow-other-keys)
+             (install-file "shellcheck.1"
+                           (string-append (assoc-ref outputs "out")
+                                          "/share/man/man1/"))
+             #t)))))
     (inputs
      `(("ghc-aeson" ,ghc-aeson)
        ("ghc-diff" ,ghc-diff)
        ("ghc-quickcheck" ,ghc-quickcheck)
        ("ghc-regex-tdfa" ,ghc-regex-tdfa)))
+    (native-inputs
+     `(("pandoc" ,pandoc)))
     (home-page "https://www.shellcheck.net/")
     (synopsis "Static analysis for shell scripts")
     (description "@code{shellcheck} provides static analysis for