[bug#55518] gnu: Add python-gatt.
Commit Message
---
Here we go; would this work? Do I need to include what the acronym means in
every instance of @acronym or does doing so for just the first instance work?
gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Comments
On 19 May 2022 06:05:22 UTC, "Wamm K. D" <jaft.r@outlook.com> wrote:
>---
>Do I need to include what the acronym means in
>every instance of @acronym or does doing so for just the first instance work?
Just the first occurence in each description. At least how Guix renders Texinfo (simple & stupid), it would repeat the meaning in brackets every single time. Not what you want.
Kind regards,
T G-R
Sent on the go. Excuse or enjoy my brevity.
> On Thursday, May 19, 2022, 08:24:43 AM CDT, Tobias Geerinckx-Rice <me@tobias.gr> wrote:
>
>
>
>
>
> On 19 May 2022 06:05:22 UTC, "Wamm K. D" <jaft.r@outlook.com> wrote:
>
> >---
> >Do I need to include what the acronym means in
> >every instance of @acronym or does doing so for just the first instance work?
>
>
> Just the first occurence in each description. At least how Guix renders Texinfo (simple & stupid), it would repeat the meaning in brackets every single time. Not what you want.
Gotcha; that's what I was figuring but wanted to double check. Thanks a ton for confirming!
Then I think the necessary changes have been made, Jack; lemme know if there's any other adjustments I ought to make.
@@ -31177,3 +31177,33 @@ (define-public python-deepmerge
"The @code{deep-merge} Python library provides a toolset to deeply merge
nested data structures in Python like lists and dictionaries.")
(license license:expat)))
+
+(define python-gatt
+ (package
+ (name "python-gatt")
+ (version "0.2.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gatt" version))
+ (sha256 (base32
+ "0fjf066jixk30fr8xwfalwfnhqpr56yv0cccyypnx2qp9bi9svb2"))))
+ (inputs (list python-dbus python-pygobject))
+ (build-system python-build-system)
+ (home-page "https://github.com/getsenic/gatt-python")
+ (synopsis "Bluetooth GATT SDK for Python")
+ (description "The Bluetooth @acronym{GATT, Generic ATTribute Profile}
+@acronym{SDK, Software Development Kit} for Python helps you implementing and
+communicating with any Bluetooth Low Energy device that has a @acronym{GATT}
+profile. It supports:
+@itemize @bullet
+@item Discovering nearby Bluetooth Low Energy devices
+@item Connecting and disconnecting devices
+@item Implementing your custom @acronym{GATT} profile
+@item Accessing all @acronym{GATT} services
+@item Accessing all @acronym{GATT} characteristics
+@item Reading characteristic values
+@item Writing characteristic values
+@item Subscribing for characteristic value change notifications
+@end itemize
+Currently, Linux is the only platform supported by this library.")
+ (license license:expat)))