diff mbox series

[bug#55518] gnu: Add python-gatt.

Message ID BY5PR07MB7029CFFA8132BD551FF0CD0799D09@BY5PR07MB7029.namprd07.prod.outlook.com
State Accepted
Headers show
Series [bug#55518] gnu: Add python-gatt. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wamm K. D May 19, 2022, 5:24 a.m. UTC
---
This isn't the end-goal package to add but a dependency.

'Trying to add Siglo so sending this one, first; Siglo will follow.

 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Jack Hill May 19, 2022, 5:46 a.m. UTC | #1
On Thu, 19 May 2022, Wamm K. D wrote:

> ---
> This isn't the end-goal package to add but a dependency.
>
> 'Trying to add Siglo so sending this one, first; Siglo will follow.
>
> gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
> 1 file changed, 29 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 5094ef068c..ee7850b518 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -31177,3 +31177,32 @@ (define-public python-deepmerge
>      "The @code{deep-merge} Python library provides a toolset to deeply merge
> nested data structures in Python like lists and dictionaries.")
>     (license license:expat)))
> +
> +(define python-gatt
> +  (package
> +    (name "python-gatt")
> +    (version "0.2.7")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "gatt" version))
> +              (sha256 (base32
> +                       "0fjf066jixk30fr8xwfalwfnhqpr56yv0cccyypnx2qp9bi9svb2"))))
> +    (inputs (list python-dbus python-pygobject))
> +    (build-system python-build-system)
> +    (home-page "https://github.com/getsenic/gatt-python")
> +    (synopsis "Bluetooth GATT SDK for Python")
> +    (description "The Bluetooth GATT SDK for Python helps you implementing and
> +communicating with any Bluetooth Low Energy device that has a GATT profile.  It
> +supports:
> +@itemize @bullet
> +@item Discovering nearby Bluetooth Low Energy devices
> +@item Connecting and disconnecting devices
> +@item Implementing your custom GATT profile
> +@item Accessing all GATT services
> +@item Accessing all GATT characteristics
> +@item Reading characteristic values
> +@item Writing characteristic values
> +@item Subscribing for characteristic value change notifications
> +@end itemize
> +Currently Linux is the only platform supported by this library.")
> +    (license license:expat)))

Cool! I haven't reviewed the package, but it looks straight forward, which 
is promising. However reading this description made me realize that I 
don't know what GATT means. Would it make sense to define it in the 
description (perhaps using texinfo's @acronym syntax)?

Best,
Jack
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5094ef068c..ee7850b518 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31177,3 +31177,32 @@  (define-public python-deepmerge
      "The @code{deep-merge} Python library provides a toolset to deeply merge
 nested data structures in Python like lists and dictionaries.")
     (license license:expat)))
+
+(define python-gatt
+  (package
+    (name "python-gatt")
+    (version "0.2.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "gatt" version))
+              (sha256 (base32
+                       "0fjf066jixk30fr8xwfalwfnhqpr56yv0cccyypnx2qp9bi9svb2"))))
+    (inputs (list python-dbus python-pygobject))
+    (build-system python-build-system)
+    (home-page "https://github.com/getsenic/gatt-python")
+    (synopsis "Bluetooth GATT SDK for Python")
+    (description "The Bluetooth GATT SDK for Python helps you implementing and
+communicating with any Bluetooth Low Energy device that has a GATT profile.  It
+supports:
+@itemize @bullet
+@item Discovering nearby Bluetooth Low Energy devices
+@item Connecting and disconnecting devices
+@item Implementing your custom GATT profile
+@item Accessing all GATT services
+@item Accessing all GATT characteristics
+@item Reading characteristic values
+@item Writing characteristic values
+@item Subscribing for characteristic value change notifications
+@end itemize
+Currently Linux is the only platform supported by this library.")
+    (license license:expat)))