diff mbox series

[bug#63558] gnu: Add qutebrowser/wayland.

Message ID BY5PR07MB7029A0E1B51171AF4FA0EB55997E9@BY5PR07MB7029.namprd07.prod.outlook.com
State New
Headers show
Series [bug#63558] gnu: Add qutebrowser/wayland. | expand

Commit Message

Wamm K. D May 17, 2023, 8 p.m. UTC
* gnu/packages/web-browsers.scm (qutebrowser/wayland): New variable.
---
Create a package that can be used with Wayland, like UnGoogled
Chromium and Icecat have.

 gnu/packages/web-browsers.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Maxim Cournoyer Sept. 1, 2023, 2:26 p.m. UTC | #1
Hi,

"Wamm K. D" <jaft.r@outlook.com> writes:

> * gnu/packages/web-browsers.scm (qutebrowser/wayland): New variable.
> ---
> Create a package that can be used with Wayland, like UnGoogled
> Chromium and Icecat have.

There's a difference though; here qutebrowser uses Qt, and qtwayland
works as a plugin, so as long as it's found in your user profile it
should just work.  Is it not the case?

I'd like to avoid adding package variants if possible.
Wamm K. D Sept. 2, 2023, 6:04 a.m. UTC | #2
I'm running XWayland and, at one point, it just stopped working (would launch in X, instead); it's been a while since I ran it (I've been running this version, instead) but I think that was why I wrote this up. Even when it was working, launching it from an X app. would cause it to run as X. I remember it being really annoying in unexpected ways and not always predictable.    On Friday, September 1, 2023 at 09:26:49 AM CDT, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:  
 
 Hi,

"Wamm K. D" <jaft.r@outlook.com> writes:

> * gnu/packages/web-browsers.scm (qutebrowser/wayland): New variable.
> ---
> Create a package that can be used with Wayland, like UnGoogled
> Chromium and Icecat have.

There's a difference though; here qutebrowser uses Qt, and qtwayland
works as a plugin, so as long as it's found in your user profile it
should just work.  Is it not the case?

I'd like to avoid adding package variants if possible.
Maxim Cournoyer Sept. 3, 2023, 2:53 p.m. UTC | #3
tags 63558 + notabug
quit

Hello,

Jaft <jaft.r@outlook.com> writes:

>  I'm running XWayland and, at one point, it just stopped working
> (would launch in X, instead); it's been a while since I ran it (I've
> been running this version, instead) but I think that was why I wrote
> this up. Even when it was working, launching it from an X app. would
> cause it to run as X. I remember it being really annoying in
> unexpected ways and not always predictable.  On Friday, September 1,
> 2023 at 09:26:49 AM CDT, Maxim Cournoyer <maxim.cournoyer@gmail.com>
> wrote:

OK; I'll close the issue, but if someone else encounters a problem
attempting to use qutebrowser on wayland (despite installing qtwayland
in their user profile), let's reopen and revisit it.
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 33de0039838..eec818f9261 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2021 Alexander Krotov <krotov@iitp.ru>
 ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
+;;; Copyright © 2023 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -548,6 +549,21 @@  (define-public qutebrowser
 GUI.  It is based on PyQt5 and QtWebEngine.")
     (license license:gpl3+)))
 
+(define-public qutebrowser/wayland
+  (package/inherit qutebrowser
+    (name "qutebrowser-wayland")
+    (inputs (modify-inputs (package-inputs qutebrowser)
+              (prepend qtwayland-5)))
+    (arguments (substitute-keyword-arguments (package-arguments qutebrowser)
+                 ((#:phases phases)
+                  #~(modify-phases #$phases
+                      (add-after 'wrap-qt-process-path 'wrap-qtwebengine-path
+                        (lambda* (#:key inputs outputs #:allow-other-keys)
+                          (wrap-program (search-input-file outputs "bin/qutebrowser")
+                            `("QT_PLUGIN_PATH" =
+                              (,(string-append (assoc-ref inputs "qtwayland")
+                                               "/lib/qt5/plugins/"))))))))))))
+
 (define-public vimb
   (package
     (name "vimb")