diff mbox series

[bug#64813] gnu: Add python-manimpango.

Message ID BY5PR07MB70299A6A356516D5B3E83FB5993DA@BY5PR07MB7029.namprd07.prod.outlook.com
State New
Headers show
Series [bug#64813] gnu: Add python-manimpango. | expand

Commit Message

Wamm K. D July 23, 2023, 8:57 p.m. UTC
* gnu/packages/python-xyz.scm (python-manimpango): New variable.
---
 gnu/packages/python-xyz.scm | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Aug. 16, 2023, 8:35 p.m. UTC | #1
Hi,

"Wamm K. D" <jaft.r@outlook.com> skribis:

> * gnu/packages/python-xyz.scm (python-manimpango): New variable.
> ---
>  gnu/packages/python-xyz.scm | 22 +++++++++++++++++++++-
>  1 file changed, 21 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index db3e69fb45..14cb375a8a 100644
>
> Right now, the tests are failing with "No module named 'manimpango.cmanimpango'";
> it's clearly trying to import the package so it can use it for testing but the
> test files are failing to find it (it looks like the "cmanimpango" file is a C
> file (along with .pxd and .pyx files) so maybe it's Cython related?).
>
> Is there a way we usually handle this for Python/Cython packages?

I don’t know if there are specific tricks here, though maybe you could
grep around or look for other packages that depend on Cython?

HTH,
Ludo’.
Troy Figiel Dec. 16, 2023, 7:26 p.m. UTC | #2
Hi both of you,

I took the liberty to

- fix the build (the extensions still needed to be built)
- upgrade to the latest release
- rebase on master

Hope this helps!

Best wishes,

Troy
Sharlatan Hellseher Jan. 20, 2024, 9:42 p.m. UTC | #3
I've added Co-author-by Troy Figiel <troy@troyfigiel.com>, updated home-page to
https://manimpango.manim.community/, applied G-Expressions package style.

Pushed as 782d69fb7f88eeb5ea470f365d8ecbc761dfa1ff

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db3e69fb45..14cb375a8a 100644

Right now, the tests are failing with "No module named 'manimpango.cmanimpango'";
it's clearly trying to import the package so it can use it for testing but the
test files are failing to find it (it looks like the "cmanimpango" file is a C
file (along with .pxd and .pyx files) so maybe it's Cython related?).

Is there a way we usually handle this for Python/Cython packages?
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,7 +119,7 @@ 
 ;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
 ;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
-;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
@@ -9292,6 +9292,26 @@  (define-public python-xcffib
 support for Python 3 and PyPy.  It is based on cffi.")
     (license license:expat)))
 
+(define-public python-manimpango
+  (package
+    (name "python-manimpango")
+    (version "0.4.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "ManimPango" version))
+              (sha256 (base32
+                       "00x1l55wy0k6v3b6l2g5603zk5d5dab59fwkxq6jq4ncifwiqbvk"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list pkg-config python-cython python-pytest))
+    (inputs (list pango))
+    (home-page "https://pypi.org/project/ManimPango/")
+    (synopsis "Bindings for Pango for using with Manim.")
+    (description "Python bindings for ManimPango which is a C binding for Pango,
+using Cython.
+
+ManimPango is internally used in Manim to render (non-LaTeX) text.")
+    (license license:expat)))
+
 (define-public python-cairocffi
   (package
     (name "python-cairocffi")