diff mbox series

[bug#63597] gnu: Add show-me-the-key.

Message ID BY5PR07MB702999C50649AA406DF022A6997D9@BY5PR07MB7029.namprd07.prod.outlook.com
State New
Headers show
Series [bug#63597] gnu: Add show-me-the-key. | expand

Commit Message

Wamm K. D May 20, 2023, 2:56 a.m. UTC
* gnu/packages/xdisorg.scm (show-me-the-key): New variable.
---
 gnu/packages/xdisorg.scm | 33 ++++++++++++++++++++++++++++++++-
 1 file changed, 32 insertions(+), 1 deletion(-)

Comments

Nicolas Goaziou July 1, 2023, 11:12 a.m. UTC | #1
Hello,

"Wamm K. D" <jaft.r@outlook.com> writes:

> * gnu/packages/xdisorg.scm (show-me-the-key): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 008b2fdb75b..40ca7c68487 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -55,7 +55,7 @@ 
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Derek Chuank <derekchuank@outlook.com>
-;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
 ;;; Copyright © 2022 Tobias Kortkamp <tobias.kortkamp@gmail.com>
 ;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
 ;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
@@ -129,6 +129,7 @@  (define-module (gnu packages xdisorg)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages polkit)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
@@ -3509,3 +3510,33 @@  (define-public xforms-gl
                          (append mesa)))
     (synopsis
      "GUI toolkit for X based on the X11 Xlib library, with OpenGL support")))
+
+(define-public show-me-the-key
+  (package
+    (name "show-me-the-key")
+    (version "1.8.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/AlynxZhou/showmethekey/")
+                    (commit (string-append "v" version))))
+              (sha256 (base32
+                       "1gvrri6kfywxk8hfchc66r6fpwlrcai2j227ib33w6503cx66rl9"))))
+    (build-system meson-build-system)
+    (inputs (list libevdev
+                  libinput
+                  gtk
+                  json-glib-minimal
+                  cairo
+                  pango
+                  libxkbcommon
+                  polkit))
+    (native-inputs (list `(,glib "bin") ; for glib-compile-resources
+                         `(,gtk  "bin") ; for gtk-update-icon-cache
+                         pkg-config))
+    (home-page "https://github.com/AlynxZhou/showmethekey")
+    (synopsis "Screencast tool to display pressed keys")
+    (description "Show Me the Key is a screencast tool to display your keys
+and works under both Xorg and Wayland (via @code{libinput}), inspired by
+@code{python-screenkey}.")
+    (license license:asl2.0)))