diff mbox series

[bug#49339,core-updates] gnu: mesa: Update to 21.1.4.

Message ID BQrzHJLVQjFdhpZvR_NV2rqGaVlbj7IY_NT8pcNAGQA-9IeWQDPpk1A1bRF76EXDg6wfqlIsqwixnjEiL7tRoXJhnqQKYj5N_hBQ3WDg374=@protonmail.com
State Accepted
Headers show
Series [bug#49339,core-updates] gnu: mesa: Update to 21.1.4. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias July 8, 2021, 3:40 p.m. UTC
Hello,

Here is a patch for just the minimal Mesa version bump. I reverted option changes to match the previous version (and wasn't sure with there being a mesa-opencl package already).

All Mesa tests pass for me too (on x86_64), so mesa-skip-tests.patch is not applied, as per original patch here. src/compiler/glsl/tests/cache_test.c has moved to src/util/tests/cache and has changed. However, the test works for me (compiling on foreign distro). The i686 part of the patch can still be applied, but will need someone to test.

This is just the Mesa change, it relies on libdrm update in https://issues.guix.gnu.org/49412

I think other than the tests patch, should be good to go, can someone review and check the i686 patch so we can move ahead with this?

Thanks,
John
diff mbox series

Patch

From a67d3224c13e6a3339865177d3a54489f5d0f582 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Thu, 8 Jul 2021 11:15:48 -0400
Subject: [PATCH] gnu: mesa: Update to 21.1.4.

* gnu/packages/gl.scm (mesa): Update to 21.1.4.
---
 gnu/packages/gl.scm | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index cc5131b28d..70762faefd 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -237,7 +237,7 @@  also known as DXTn or DXTC) for Mesa.")
 (define-public mesa
   (package
     (name "mesa")
-    (version "20.2.6")
+    (version "21.1.4")
     (source
       (origin
         (method url-fetch)
@@ -249,9 +249,7 @@  also known as DXTn or DXTC) for Mesa.")
                                   version "/mesa-" version ".tar.xz")))
         (sha256
          (base32
-          "1nw5k2qrlcrp5bljy1lmyybgl525y0h44synkbbirw92qv3a6b7i"))
-        (patches
-         (search-patches "mesa-skip-tests.patch"))))
+          "02z9g6zpkg1p1sm8f84xdi7v2n7x534x9pn565bvcr411527y5qz"))))
     (build-system meson-build-system)
     (propagated-inputs
       `(;; The following are in the Requires.private field of gl.pc.
@@ -309,7 +307,7 @@  also known as DXTn or DXTC) for Mesa.")
          "-Dglx=dri"        ;Thread Local Storage, improves performance
          ;; "-Dopencl=true"
          ;; "-Domx=true"
-         "-Dosmesa=gallium"
+         "-Dosmesa=true"
          "-Dgallium-xa=enabled"
 
          ;; features required by wayland
@@ -417,8 +415,8 @@  also known as DXTn or DXTC) for Mesa.")
              (let ((out (assoc-ref outputs "out"))
                    (bin (assoc-ref outputs "bin")))
                ;; Not all architectures have the Vulkan overlay control script.
-               (mkdir-p (string-append bin "/bin"))
-               (call-with-output-file (string-append bin "/bin/.empty")
+               (mkdir-p (string-append out "/bin"))
+               (call-with-output-file (string-append out "/bin/.empty")
                  (const #t))
                (copy-recursively (string-append out "/bin")
                                  (string-append bin "/bin"))
-- 
2.32.0