diff mbox series

[bug#52030] gnu: Add feather font

Message ID BN8PR19MB244907B206BEBE03E897488099779@BN8PR19MB2449.namprd19.prod.outlook.com
State Accepted
Headers show
Series [bug#52030] gnu: Add feather font | expand

Commit Message

Wamm K. D Dec. 16, 2021, 9:24 p.m. UTC
> On Friday, December 10, 2021, 08:28:42 AM CST, Ludovic Courtès <ludo@gnu.org> wrote: 
>
>
>
>
>
> Hi Jaft,
>
> > +    (name "font-atui-feather")
> > +    (version "0")
> > +    (source (origin
> > +              (method url-fetch/zipbomb)
> > +              (uri "https://github.com/AT-UI/feather-font/archive/refs/heads/master.zip")
> > +              (sha256 (base32 "0lp1m1a47s56rj0q6nj8j5snkbw8jq3q7zwdzf86sbbglq170inh"))))
>
> Note that ‘master.zip’ changes at each commit (and its content can also
> change even if the HEAD commit is unchanged because it’s a generated
> file.)
>
> Could you instead change it to refer to a non-generated zip file, or use
> ‘git-fetch’ to obtain a checkout?
>
> You may also need to adjust the version string.

Huh; sorry about that. I knew that and yet completely missed it, when writing this up. The repo. doesn't have any tags or releases (maybe that's what my brain was thinking when it originally used master) so I've just pointed it to the latest commit they'd made, in the revision.

> > +    (build-system font-build-system)
> > +    (home-page "https://at-ui.github.io/feather-font/")
> > +    (synopsis "Iconfont version of Feather")
> +    (description "Feather is a collection of simply beautiful open source icons.
>
> Everything is free software/data in Guix, so you can remove “open
> source”.  :-)

Haha; oh, right: fair point. Removed.

> Could you send an updated patch?  Preferably as a attachment to make
> sure it’s not mangled on its way.
>
> Thanks in advance!
>
> Ludo’.

For some reason, I only remembered the part of the documentation that says you can submit the patch in the body of the E-mail but, double-checking my memory, it definitely also lists being able to send the patch as an attachment. I'll start doing that as others have mentioned mangling, as well.

Comments

Ludovic Courtès Feb. 27, 2022, 9:40 p.m. UTC | #1
Hi,

Jaft <jaft.r@outlook.com> skribis:

> For some reason, I only remembered the part of the documentation that says you can submit the patch in the body of the E-mail but, double-checking my memory, it definitely also lists being able to send the patch as an attachment. I'll start doing that as others have mentioned mangling, as well.
>
> * gnu/packages/fonts.scm (feather): Add Feather iconfont by AT-UI

[...]

> +(define-public font-atui-feather
> +  (package
> +    (name "font-atui-feather")
> +    (version "0")
> +    (source (origin
> +            (method git-fetch)
> +            (uri (git-reference
> +                  (commit "c51fe7cedbcf2cbf4f1b993cef5d8def612dec1d")
> +                  (url "https://github.com/AT-UI/feather-font/")))
> +            (sha256 (base32 "0hk12bjlsh0j6kd0sz3nwax259afdi6dxws4x88yz5ssxic1ng2j"))))
> +    (build-system font-build-system)
> +    (home-page "https://at-ui.github.io/feather-font/")
> +    (synopsis "Iconfont version of Feather")
> +    (description "Feather is a collection of simply beautiful icons.
> +Each icon is designed on a 24x24 grid with an emphasis on simplicity, consistency,
> +and readability.  This package bundles those icons into a font.")
> +    (license license:expat)))

I’ve (finally!) committed a tweaked version that includes a ‘version’
field following the guidelines in
<https://guix.gnu.org/manual/devel/en/html_node/Version-Numbers.html>,
also addressing another ‘guix lint’ warning about the origin.

Jaft <jaft.r@outlook.com> skribis:

> I don't know if it's generally considered poor etiquette to do this but just bumping this E-mail thread, as I believe I've done the required changes and, theoretically, this patch should be all ready to just go.

No, you were right to ping me; apologies for missing your earlier email.

In the future, it’s even more convenient for us if you can send a patch
created with ‘git send-email’.

Thank you, and sorry for the delay!

Ludo’.
diff mbox series

Patch

* gnu/packages/fonts.scm (feather): Add Feather iconfont by AT-UI
---
gnu/packages/fonts.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 63d1240d5c..262ca3adfa 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -42,6 +42,7 @@ 
 ;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2288,3 +2289,21 @@  (define-public font-overpass
 Overpass includes proportional and monospace variants.")
     (license (list license:silofl1.1
                    license:lgpl2.1))))
+
+(define-public font-atui-feather
+  (package
+    (name "font-atui-feather")
+    (version "0")
+    (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (commit "c51fe7cedbcf2cbf4f1b993cef5d8def612dec1d")
+                  (url "https://github.com/AT-UI/feather-font/")))
+            (sha256 (base32 "0hk12bjlsh0j6kd0sz3nwax259afdi6dxws4x88yz5ssxic1ng2j"))))
+    (build-system font-build-system)
+    (home-page "https://at-ui.github.io/feather-font/")
+    (synopsis "Iconfont version of Feather")
+    (description "Feather is a collection of simply beautiful icons.
+Each icon is designed on a 24x24 grid with an emphasis on simplicity, consistency,
+and readability.  This package bundles those icons into a font.")
+    (license license:expat)))