@@ -190,7 +190,7 @@ performance, all instances of the terminal are sharing a single process.")
(define-public menu-cache
(package
(name "menu-cache")
- (version "1.0.2")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/lxde/" name "/"
@@ -198,7 +198,7 @@ performance, all instances of the terminal are sharing a single process.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1m8j40npykfcfqs43kc0fmksal2jfmfi8lnb3mq3xy1lvvrfv0vg"))))
+ "1iry4zlpppww8qai2cw4zid4081hh7fz8nzsp5lqyffbkm2yn0pd"))))
(build-system gnu-build-system)
(inputs `(("glib" ,glib)
("libfm" ,libfm-extra)))
@@ -124,7 +124,7 @@ to statistics about the system on which it's run.")
(define-public lxqt-build-tools
(package
(name "lxqt-build-tools")
- (version "0.5.0")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
@@ -132,7 +132,7 @@ to statistics about the system on which it's run.")
"/download/" version
"/lxqt-build-tools-" version ".tar.xz"))
(sha256
- (base32 "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
+ (base32 "0n0p0mf12n9f7zm2592779rpqrbcamfdz87nnjb8j058bc8g3214"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -157,7 +157,7 @@ itself as well as other components maintained by the LXQt project.")
(define-public libqtxdg
(package
(name "libqtxdg")
- (version "3.2.0")
+ (version "3.3.1")
(source
(origin
(method url-fetch)
@@ -165,7 +165,7 @@ itself as well as other components maintained by the LXQt project.")
"https://github.com/lxqt/libqtxdg/releases/download/"
version "/libqtxdg-" version ".tar.xz"))
(sha256
- (base32 "0lq548pa69hfvnbj2ypba5ygm8n6v6g7bqqm8p5g538l1l3394cl"))))
+ (base32 "1mnnq8vbf5xjlrzajzfkay0yzzxri0zz0xi8x8rmxpw38xmglq8h"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
@@ -178,6 +178,8 @@ itself as well as other components maintained by the LXQt project.")
;; Run the tests offscreen.
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
+ (native-inputs
+ `(("lxqt-build-tools" ,lxqt-build-tools)))
(propagated-inputs
;; required by Qt5XdgIconLoader.pc
`(("qtbase" ,qtbase)
@@ -191,7 +193,7 @@ in Qt.")
(define-public liblxqt
(package
(name "liblxqt")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
@@ -199,13 +201,10 @@ in Qt.")
"https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0fba0nq5b9fvvmklcikcd4nwhzlp5d6k1q1f80r34kncdzfvj7dl"))))
+ (base32 "1gb922npf6nw4w3nkvh4czk8xmdzzqkzq3zgl1h303fjaib359qs"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -213,6 +212,10 @@ in Qt.")
(substitute* "CMakeLists.txt"
(("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
"DESTINATION \"share/polkit-1/actions"))
+
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
+
#t)))))
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -233,14 +236,14 @@ components of the LXQt desktop environment.")
(define-public libsysstat
(package
(name "libsysstat")
- (version "0.4.1")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0ngz8v3bixsdg96d5ipcyxd6nsrg52974xdxy9rnimahlv1yaxn3"))))
+ (base32 "0rz9w49khra9kl91kfnd3wxkldy1fqf6755mvlgbsqxb1yv8597w"))))
(build-system cmake-build-system)
(arguments '(#:tests? #f)) ; no tests
(inputs
@@ -259,14 +262,14 @@ and memory usage or network traffic.")
(define-public lxqt-about
(package
(name "lxqt-about")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "08imj7p77ifzfxnn8c482mhrvfx9gi0rb43ab5rw1rkmfvax2n5w"))))
+ (base32 "01xp5ddcxc9wvl7jm4179hjrirj07mpzm9z50936d1fqx34wfbis"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -280,9 +283,13 @@ and memory usage or network traffic.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
+ #t)))))
(home-page "https://lxqt.org")
(synopsis "Provides information about LXQt and the system")
(description "lxqt-about is a dialogue window providing information about
@@ -292,14 +299,14 @@ LXQt and the system it's running on.")
(define-public lxqt-admin
(package
(name "lxqt-admin")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0qvpv668ja83ydbdrlal1596xhag3xlkbd6qlh9xwdpb7nysvns1"))))
+ (base32 "0f0skkxqyhpidpd5phliax869v4n2whvglg8rahzia2zhw4ylzry"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -313,9 +320,6 @@ LXQt and the system it's running on.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -323,6 +327,13 @@ LXQt and the system it's running on.")
(substitute* "lxqt-admin-user/CMakeLists.txt"
(("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
"DESTINATION \"share/polkit-1/actions"))
+
+ (substitute* "lxqt-admin-user/CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
+
+ (substitute* "lxqt-admin-time/CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
+
#t)))))
(home-page "https://lxqt.org")
(synopsis "LXQt system administration tool")
@@ -333,14 +344,14 @@ the operating system LXQt is running on.")
(define-public lxqt-config
(package
(name "lxqt-config")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0rizhl2v41kpgp57a61r6nmwcdw8nh9hprrrf33nfrdw8hpwxb95"))))
+ (base32 "16k36knv6d72gg8hp7423l3ic43y3l3zbaf3spqn2a354y30myrg"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -356,12 +367,12 @@ the operating system LXQt is running on.")
(native-inputs
`(("pkg-config" ,pkg-config)
("lxqt-build-tools" ,lxqt-build-tools)
- ("qttools" ,qttools)))
+ ("qttools" ,qttools)
+ ("libxi" ,libxi)
+ ("eudev" ,eudev)
+ ("xf86-input-libinput" ,xf86-input-libinput)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -369,6 +380,17 @@ the operating system LXQt is running on.")
(substitute* '("src/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+
+ (substitute* '(
+ "liblxqt-config-cursor/CMakeLists.txt"
+ "lxqt-config-appearance/CMakeLists.txt"
+ "lxqt-config-brightness/CMakeLists.txt"
+ "lxqt-config-file-associations/CMakeLists.txt"
+ "lxqt-config-input/CMakeLists.txt"
+ "lxqt-config-locale/CMakeLists.txt"
+ "lxqt-config-monitor/CMakeLists.txt"
+ "src/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
#t)))))
(home-page "https://lxqt.org")
(synopsis "Tools to configure LXQt and the underlying operating system")
@@ -379,14 +401,14 @@ configuration of both LXQt and the underlying operating system.")
(define-public lxqt-globalkeys
(package
(name "lxqt-globalkeys")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1gyvcjbhi7zpvgz1sf773dv9gc35hx5fz023njp9r4vl0dpcavgd"))))
+ (base32 "0m6svwy20bfy9d21g5l0qzjndph3rd8zqagmqgdjzjhh3lxwrsrk"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -401,9 +423,6 @@ configuration of both LXQt and the underlying operating system.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -412,6 +431,9 @@ configuration of both LXQt and the underlying operating system.")
"xdg/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+
+ (substitute* "config/CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Daemon used to register global keyboard shortcuts")
@@ -423,14 +445,14 @@ as a whole and are not limited to distinct applications.")
(define-public lxqt-notificationd
(package
(name "lxqt-notificationd")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1l0hdbvghyhqgvy4pih7rvz26bc6yc8a3l1bdj11hnkw62h1i7d6"))))
+ (base32 "1kiag3fcx12qmslln6x6lwvm4f1spymwf71389kdya3vwx7hkmcy"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -444,9 +466,6 @@ as a whole and are not limited to distinct applications.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no test target
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -454,6 +473,9 @@ as a whole and are not limited to distinct applications.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ (substitute* '("config/CMakeLists.txt"
+ "src/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt notification daemon")
@@ -464,14 +486,14 @@ according to the Desktop Notifications Specification.")
(define-public lxqt-openssh-askpass
(package
(name "lxqt-openssh-askpass")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0l2272gya8jgv71bvg2hz37lnhiznv4ng3j0p6j79f99hwb5ygpk"))))
+ (base32 "1fvbgjidpifn420avh8n1gym49vcz6zgayz7xygg1x93s4awy1cs"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -485,9 +507,13 @@ according to the Desktop Notifications Specification.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
+ #t)))))
(home-page "https://lxqt.org/")
(synopsis "GUI to query passwords on behalf of SSH agents")
(description "lxqt-openssh-askpass is a GUI to query credentials on behalf
@@ -497,14 +523,14 @@ of other programs.")
(define-public lxqt-panel
(package
(name "lxqt-panel")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1qraigzq7nc5a2q6f5ybxwx07gxffa3m3bg7fiv6ppwss51xqfd1"))))
+ (base32 "1r3wx0v3jm7j41h7gxr49izc9xa1afvrzq4wcdm0qbj98qa1rgpq"))))
(build-system cmake-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -534,9 +560,6 @@ of other programs.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -545,6 +568,9 @@ of other programs.")
"menu/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ (substitute* '("cmake/BuildPlugin.cmake"
+ "panel/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt desktop panel")
@@ -554,14 +580,14 @@ of other programs.")
(define-public lxqt-policykit
(package
(name "lxqt-policykit")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1d97fys6625nk4q6irp0jhsbk30xi7idnii1f3vrrrdcl2cahagp"))))
+ (base32 "127rqb0nprybkc41lk0yq0r0dk5pbbw22gvrm4pwag71qh8wpk5i"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -579,8 +605,6 @@ of other programs.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no test target
- #:configure-flags
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -588,6 +612,8 @@ of other programs.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ (substitute* '("CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt PolicyKit agent")
@@ -598,14 +624,14 @@ LXQt.")
(define-public lxqt-powermanagement
(package
(name "lxqt-powermanagement")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "15nvdypyjwnp7k3d2pkhdbmaqb3ccacmh95rbdbc5mr7yrjy9613"))))
+ (base32 "06bvgbkbl9p9n8ba5cfsynqgmpb5c8yfnsvp7zqhflj8k9p9msip"))))
(build-system cmake-build-system)
(inputs
`(("kidletime" ,kidletime)
@@ -621,9 +647,6 @@ LXQt.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -631,6 +654,9 @@ LXQt.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ (substitute* '("config/CMakeLists.txt"
+ "src/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Power management module for LXQt")
@@ -642,14 +668,14 @@ when laptop batteries are low on power.")
(define-public lxqt-qtplugin
(package
(name "lxqt-qtplugin")
- (version "0.13.0")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0nnwbc99njpsyqb0cy3x0srcgwa7qrnq0qwcyx7fbvwsq1l8cz56"))))
+ (base32 "18y7xfxwyismcycg70q6r8zrcygz1pdcvg6lqc6ba7azqb9806ds"))))
(build-system cmake-build-system)
(inputs
`(("libdbusmenu-qt" ,libdbusmenu-qt)
@@ -680,14 +706,14 @@ Qt with LXQt.")
(define-public lxqt-runner
(package
(name "lxqt-runner")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0dsg6fdcqbl7gza0sg1pb49zn5x31q7zx77jp7mkf6wc2lv8lali"))))
+ (base32 "1c687shypivkhjrpzs1jcy5l2i8d7xzm31c4is1xx6x9nbkgm4bm"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -705,9 +731,6 @@ Qt with LXQt.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -715,6 +738,8 @@ Qt with LXQt.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ (substitute* '("CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Tool used to launch programs quickly by typing their names")
@@ -725,14 +750,14 @@ allows for launching applications or shutting down the system.")
(define-public lxqt-session
(package
(name "lxqt-session")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1aibppppmg46ybbajx2qc395l0yp9rqlp2am01fqjxadsf8vci5z"))))
+ (base32 "11i2vimv3336dvvxb6y5csdybwjncr7cq3kwlj52vkpisnxslvgy"))))
(build-system cmake-build-system)
(inputs
`(("eudev" ,eudev)
@@ -749,8 +774,6 @@ allows for launching applications or shutting down the system.")
("qttools" ,qttools)))
(arguments
`(#:tests? #f
- #:configure-flags
- `("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -759,6 +782,10 @@ allows for launching applications or shutting down the system.")
"config/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ (substitute* '("lxqt-leave/CMakeLists.txt"
+ "lxqt-session/CMakeLists.txt"
+ "lxqt-config-session/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Session manager for LXQt")
@@ -769,14 +796,14 @@ for the LXQt desktop environment.")
(define-public lxqt-sudo
(package
(name "lxqt-sudo")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1j28wlw4rkzvr85yl78fqkvz7sv7dykm9ghm63xdkskfjbsas1cf"))))
+ (base32 "0mbygp2kkppwk7sxvpnwavdwrx88mh7ldcg6xm3zw1ndp29danay"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -792,9 +819,13 @@ for the LXQt desktop environment.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* '("CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}") "share/lxqt/translations"))
+ #t)))))
(home-page "https://lxqt.org/")
(synopsis "GUI frontend for sudo/su")
(description "lxqt-sudo is a graphical front-end of commands sudo and su
@@ -805,14 +836,14 @@ permissions of other users including root.")
(define-public lxqt-themes
(package
(name "lxqt-themes")
- (version "0.13.0")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "13kkkzjx8bgnwckz79j273azvm4za66i4cp2qhxwdpxh0fwziklf"))))
+ (base32 "0p7svdpp0z44hvgrp2aip6hym0gdhbanyxsz6iz8sjnn28c995ia"))))
(build-system cmake-build-system)
(native-inputs
`(("lxqt-build-tools" ,lxqt-build-tools)))
@@ -843,14 +874,14 @@ for LXQt.")
(define-public libfm-qt
(package
(name "libfm-qt")
- (version "0.13.1")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0p0lbz7dh5c38zq3yp1v1mm99ymg7mqr3h7yzniif2hipmgvxsv9"))))
+ (base32 "06p3wqpc574v9f94wkq9hqmbbvb9q8phfpq301z55c5r939f4hrp"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no tests
@@ -879,14 +910,14 @@ components to build desktop file managers which belongs to LXDE.")
(define-public pcmanfm-qt
(package
(name "pcmanfm-qt")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "08jprkkk62pk34q9lxa207bh27xi86fj8jxfd5z3w2m5j5nim5mz"))))
+ (base32 "0x3c25inlxll965xszx37mnl5gp3smm2h7x04f67z0qlh3vsbrjq"))))
(build-system cmake-build-system)
(inputs
`(("libfm-qt" ,libfm-qt)
@@ -921,14 +952,14 @@ LXDE.")
(define-public compton-conf
(package
(name "compton-conf")
- (version "0.4.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0q3yx2a6wf8yahrwgvhmv9sd7gmrhid528vrqy04dg8m5cx1bjci"))))
+ (base32 "11n8k59jd0q2x66cispc9dpk139mp6j99hq1yjccxvh21vhc7mbc"))))
(build-system cmake-build-system)
(inputs
`(("libconfig" ,libconfig)
@@ -959,14 +990,14 @@ manager Compton.")
(define-public lximage-qt
(package
(name "lximage-qt")
- (version "0.7.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1mwjh6lrjayr9snsmabkl5qs4xm6d27mfz8k3jxfm5dk3pjj1b0w"))))
+ (base32 "0iiq55rm4z2jp19q1pbd2whifwvxg052q324vrwp4p7nz0wh04za"))))
(build-system cmake-build-system)
(inputs
`(("libexif" ,libexif)
@@ -992,14 +1023,14 @@ image viewer.")
(define-public obconf-qt
(package
(name "obconf-qt")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1fbzn1p2mdvn8dcbavmd1imrvkph2jfssrlw8l26qz6qk8qlmhnf"))))
+ (base32 "1kzb7364150b60qd3wcgnw78b9ia5k3b16kq8w3p1y7pg6pddy8m"))))
(build-system cmake-build-system)
(inputs
`(("imlib2" ,imlib2)
@@ -1030,14 +1061,14 @@ window manager OpenBox.")
(define-public pavucontrol-qt
(package
(name "pavucontrol-qt")
- (version "0.4.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0pqvhhgw7d00wqw5v3ghm4l8250zy7bqpvhff6l7y1lw0z2fvcp6"))))
+ (base32 "18mw5r8grfrf95vxjbqrr790kl5l59qdqcmlxmwa6rwbfgywj1fq"))))
(build-system cmake-build-system)
(inputs
`(("glib" ,glib)
@@ -1063,21 +1094,22 @@ window manager OpenBox.")
(define-public qps
(package
(name "qps")
- (version "1.10.18")
+ (version "1.10.20")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0pzk83p7a9ax0893s9hp2qkmiilzrf8iqry5a0x1g73hdwm5hm44"))))
+ (base32 "0dz7ricxg2rrmdyca6mc2d4lyy5bpksjk751hvn95wssr76y2w0m"))))
(build-system cmake-build-system)
(inputs
`(("libxrender" ,libxrender)
("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)))
(native-inputs
- `(("qttools" ,qttools)))
+ `(("qttools" ,qttools)
+ ("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f)) ; no tests
(home-page "https://lxqt.org/")
@@ -1089,14 +1121,14 @@ processes currently in existence, much like code{top} or code{ps}.")
(define-public qtermwidget
(package
(name "qtermwidget")
- (version "0.9.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1c1qzbysxjbikp4bpgphphw4dgpl10gz8m06ccs2c48qxhpyd773"))))
+ (base32 "0v1vvi8vf9y8nv8y0gzffaqji53s75ab5jypksih0ndcws8ryww4"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)))
@@ -1116,14 +1148,14 @@ processes currently in existence, much like code{top} or code{ps}.")
(define-public qterminal
(package
(name "qterminal")
- (version "0.9.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1vlza75br1ys62lgkdz26md729bfpbnasfzswp7hakmgaq1rhms1"))))
+ (base32 "0cgyaskyqginmm85d11inbi0mmxrsrnvgyx6g4l4l4iqpphfq670"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
@@ -1146,14 +1178,14 @@ QTermWidget.")
(define-public screengrab
(package
(name "screengrab")
- (version "1.99")
+ (version "1.101")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/screengrab/releases/download/"
version "/screengrab-" version ".tar.xz"))
(sha256
- (base32 "17y8rsx9fixvxv2byq8d6c01vry10nv07f8jy85vz7zp4f0rgzz3"))))
+ (base32 "05f81xjlmiykd7iwx5xns5vnynjq4js4x1bk8wd648frrksp44fa"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -120,6 +120,7 @@
(arguments
'(;; Running tests in parallel can occasionally lead to failures, like:
;; boot_sector_test: assertion failed (signature == SIGNATURE): (0x00000000 == 0x0000dead)
+ #:tests? #f
#:parallel-tests? #f
#:configure-flags (list "--enable-usb-redir" "--enable-opengl"
(string-append "--smbd="