diff mbox series

[bug#35911] gnu: rust: Update to 1.35.0.

Message ID B8760BE9-6BCC-4DD7-8F52-AFF2CE7F3D01@gmail.com
State Accepted
Headers show
Series [bug#35911] gnu: rust: Update to 1.35.0. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ivan Petkov May 26, 2019, 3:36 a.m. UTC
From 635bab2324bcaa1d1b3031af2ebc73748a9c2325 Mon Sep 17 00:00:00 2001
From: Ivan Petkov <ivanppetkov@gmail.com>
Date: Wed, 22 May 2019 20:50:47 -0700
Subject: [PATCH] gnu: rust: Update to 1.35.0.

* gnu/packages/rust.scm (rust): Rename to...
(rust-1.34): ...this.
(rust): New variable.
---
 gnu/packages/rust.scm | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès June 13, 2019, 8:34 a.m. UTC | #1
Hi Ivan,

Ivan Petkov <ivanppetkov@gmail.com> skribis:

> From 635bab2324bcaa1d1b3031af2ebc73748a9c2325 Mon Sep 17 00:00:00 2001
> From: Ivan Petkov <ivanppetkov@gmail.com>
> Date: Wed, 22 May 2019 20:50:47 -0700
> Subject: [PATCH] gnu: rust: Update to 1.35.0.
>
> * gnu/packages/rust.scm (rust): Rename to...
> (rust-1.34): ...this.
> (rust): New variable.

I believe you can use your new commit super powers and push this patch.
:-)

Thank you,
Ludo’.
Ivan Petkov June 18, 2019, 2:53 a.m. UTC | #2
Hi Ludo,

> On Jun 13, 2019, at 1:34 AM, Ludovic Courtès <ludo@gnu.org> wrote:
> 
> I believe you can use your new commit super powers and push this patch.
> :-)

Thanks for the reminder :)
I’ve pushed this out as 0ab5e91e1ced624c51cecc2693deb7c789fe1f07.

—Ivan
Ludovic Courtès June 18, 2019, 2:19 p.m. UTC | #3
Howdy,

Ivan Petkov <ivanppetkov@gmail.com> skribis:

>> On Jun 13, 2019, at 1:34 AM, Ludovic Courtès <ludo@gnu.org> wrote:
>> 
>> I believe you can use your new commit super powers and push this patch.
>> :-)
>
> Thanks for the reminder :)
> I’ve pushed this out as 0ab5e91e1ced624c51cecc2693deb7c789fe1f07.

Awesome.  Thank you, and welcome aboard!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 3f5ec590a9..9c8088b2f7 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -1048,7 +1048,7 @@  jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
                  (setenv "RUST_TEST_THREADS" "2")
                  #t)))))))))
 
-(define-public rust
+(define-public rust-1.34
   (let ((base-rust
          (rust-bootstrapped-package rust-1.33 "1.34.1"
            "19s09k7y5j6g3y4d2rk6kg9pvq6ml94c49w6b72dmq8p9lk8bixh")))
@@ -1062,3 +1062,23 @@  jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
                       (delete-file-recursively "src/llvm-project")
                       (delete-file-recursively "vendor/jemalloc-sys/jemalloc")
                       #t)))))))
+
+(define-public rust
+  (let ((base-rust
+         (rust-bootstrapped-package rust-1.34 "1.35.0"
+           "0bbizy6b7002v1rdhrxrf5gijclbyizdhkglhp81ib3bf5x66kas")))
+    (package
+      (inherit base-rust)
+      (arguments
+       (substitute-keyword-arguments (package-arguments base-rust)
+         ((#:phases phases)
+          `(modify-phases ,phases
+             ;; The tidy test includes a pass which ensures large binaries
+             ;; don't accidentally get checked into the rust git repo.
+             ;; Unfortunately the test assumes that git is always available,
+             ;; so we'll comment out the invocation of this pass.
+             (add-after 'configure 'disable-tidy-bins-check
+               (lambda* _
+                 (substitute* "src/tools/tidy/src/main.rs"
+                   (("bins::check") "//bins::check"))
+                 #t)))))))))