diff mbox series

[bug#41181] adds emacs-interleave

Message ID Adm0HTLwEn9xKescmC35WTpS2d1P5dDE70m0dgz-HaHQuYy4R9PbAL-5-2TmWSS3KhX3wo4hpytXs-i7hsfQAkt2F2gZuQ31_hbTalaLekg=@protonmail.com
State Accepted
Headers show
Series [bug#41181] adds emacs-interleave | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

guix--- via Guix-patches via May 10, 2020, 7:35 p.m. UTC
Hello,

The attached patch adds the emacs-interleave package.

Ryan Desfosses

Comments

Nicolas Goaziou May 11, 2020, 7:10 a.m. UTC | #1
Hello,

rdes via Guix-patches via <guix-patches@gnu.org> writes:

> The attached patch adds the emacs-interleave package.

Thank you! Some comments follow.

> Subject: [PATCH] gnu: Add emacs-interleave

Your commit message should conform to Guix rules. Here, you need to add

  * gnu/packages/emacs-xyz.scm (emacs-interleave): New variable.

> +(define-public emacs-interleave
> +(package

Indentation seems wrong.

> +  (name "emacs-interleave")
> +  (version "20191129.958")
> +  (source
> +    (origin
> +      (method url-fetch)
> +      (uri (string-append
> +             "https://melpa.org/packages/interleave-"
> +             version
> +             ".el"))

We do not use MELPA sources. Instead, you could use `git-fetch' and
extract the latest stable release from here:

  https://github.com/rudolfochrist/interleave/releases

> +      (sha256
> +        (base32
> +          "0y183ggfmkjjywbcqgyinmr21hsg2vaw4d52bg1gsxbp673za2m8"))))

Nitpick: could you move the string on the same line as `base32'?

> +  (build-system emacs-build-system)
> +  (home-page
> +    "https://github.com/rudolfochrist/interleave")

Ditto. Could you move the string on the line above?

> +  (synopsis "Interleaving text books since 2015")

I think this synopsis needs to be reworded. As it is, it may not be
useful.

> +  (description
> +    "Interleave presents your PDF side by side to an [[http://orgmode.org][Org Mode]]

Description uses Texinfo syntax, not Org syntax. In this case, however,
I think "side by side to an Org buffer" is sufficient.

> +buffer with your notes, narrowing down to just those passages that are relevant to
> +the particular page in the document viewer.
> +")

You don't need to end the description with a final newline. It would be
nice to expound it a bit. For example, it could be interesting to know
this is a minor mode.

Don't forget to add a copyright line with your name at the top of the file.

Could you send an updated patch?

Regards,
diff mbox series

Patch

From 9dd929fc4ed069eee08e18efc0557a3bec27bd41 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <ryan@desfo.org>
Date: Sun, 10 May 2020 15:13:27 -0400
Subject: [PATCH] gnu: Add emacs-interleave

---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ce1b1c4b28..f09aedf43e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2184,6 +2184,31 @@  This buffer is typically shown as a sidebar (Emacs vertically splits the
 window).")
     (license license:gpl3+)))
 
+(define-public emacs-interleave
+(package
+  (name "emacs-interleave")
+  (version "20191129.958")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (string-append
+             "https://melpa.org/packages/interleave-"
+             version
+             ".el"))
+      (sha256
+        (base32
+          "0y183ggfmkjjywbcqgyinmr21hsg2vaw4d52bg1gsxbp673za2m8"))))
+  (build-system emacs-build-system)
+  (home-page
+    "https://github.com/rudolfochrist/interleave")
+  (synopsis "Interleaving text books since 2015")
+  (description
+    "Interleave presents your PDF side by side to an [[http://orgmode.org][Org Mode]]
+buffer with your notes, narrowing down to just those passages that are relevant to
+the particular page in the document viewer.
+")
+  (license license:gpl3+)))
+
 (define-public emacs-mmm-mode
   (package
     (name "emacs-mmm-mode")
-- 
2.26.2