diff mbox series

[bug#61225,3/3] gnu: supertuxkart: Update to 1.4.

Message ID ATAfYDA977C92QXvTSwEn2N171LKe3arX3za2SiB4fJZIOB7t5m3J3yR8GFP1otBPLbCIGNCxyZ2Wcafu6HQDDjRQTYCSTmU7N2jYa2rUnM=@proton.me
State New
Headers show
Series None | expand

Commit Message

Sughosha Feb. 2, 2023, 11:20 a.m. UTC
Update supertuxkart to 1.4, enable recorder and unbundle mcpp.

Comments

Ludovic Courtès Feb. 10, 2023, 11:06 p.m. UTC | #1
Hi,

Sughosha <Sughosha@proton.me> skribis:

> From 81e0fb91fff6f9ae51e6992dd0be68d0ba68da5d Mon Sep 17 00:00:00 2001
> From: Sughosha <sughosha@proton.me>
> Date: Thu, 2 Feb 2023 12:13:28 +0100
> Subject: [PATCH 3/3] gnu: supertuxkart: Update to 1.4.
>
> * gnu/packages/games.scm (supertuxkart): Update to 1.4.
>   [snippet]: Unbundle mcpp.
>   [arguments]: Enable recorder.
>   [inputs]: Add libopenglrecorder.
>   [native-inputs]: Add mcpp and python.

[...]

> From e879abbd120ffdfd0cb1c3104fbe9146aa15258e Mon Sep 17 00:00:00 2001
> From: Sughosha <sughosha@proton.me>
> Date: Thu, 2 Feb 2023 12:08:56 +0100
> Subject: [PATCH 2/3] gnu: Add libopenglrecorder.
>
> * gnu/packages/gl.scm (libopenglrecorder): New public variable.

[...]

> From 71affeda0d20521fd5f8ab23d5ea5046de68a702 Mon Sep 17 00:00:00 2001
> From: Sughosha <sughosha@proton.me>
> Date: Thu, 2 Feb 2023 12:08:13 +0100
> Subject: [PATCH 1/3] gnu: Add mcpp.
>
> * gnu/packages/cpp.scm (mcpp): New public variable.

Applied all three patches.

In the future please send patches using ‘git send-email’:

  https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html

This will ensure https://qa.guix.gnu.org can apply them and test them.

Thanks!

Ludo’.
diff mbox series

Patch

From 71affeda0d20521fd5f8ab23d5ea5046de68a702 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Thu, 2 Feb 2023 12:08:13 +0100
Subject: [PATCH 1/3] gnu: Add mcpp.

* gnu/packages/cpp.scm (mcpp): New public variable.
---
 gnu/packages/cpp.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 0eecab50fb..0a5383e35d 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1428,6 +1428,27 @@  (define-public magic-enum
 conversions to and from strings, iteration and related functionality.")
     (license license:expat)))
 
+(define-public mcpp
+  (package
+    (name "mcpp")
+    (version "2.7.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/mcpp/mcpp/"
+                                  "V." version "/mcpp-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0r48rfghjm90pkdyr4khxg783g9v98rdx2n69xn8f6c5i0hl96rv"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:configure-flags #~(list "--enable-mcpplib" "--disable-static")))
+    (home-page "https://mcpp.sourceforge.net/")
+    (synopsis "C/C++ preprocessor")
+    (description
+     "@code{mcpp} is Matsui's CPP implementation precisely conformed to
+standards.")
+    (license license:bsd-2)))
+
 (define-public cli11
   (package
     (name "cli11")
-- 
2.39.1