diff mbox series

[bug#63691,v4] gnu: Add emacs-prism.

Message ID AM0PR10MB3586B7F018180345F1FD5E7880469@AM0PR10MB3586.EURPRD10.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#63691,v4] gnu: Add emacs-prism. | expand

Commit Message

Maciej Kalandyk May 25, 2023, 6:29 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Nicolas Goaziou May 25, 2023, 8:22 p.m. UTC | #1
Hello,

Maciej Kalandyk <m.kalandyk@outlook.com> writes:

> +(define-public emacs-prism

I added a commit message and applied your patch. Thank you.

> +    (description
> +     "Prism is a Rainbow Blocks-like mode for Emacs. It preserves non-color
> +face properties and allows configuration of faces and colors.")

I added two spaces between sentences.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0ea9732bfa..356a7f2199 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1161,6 +1161,28 @@  (define-public emacs-spongebob
 buffer.")
       (license license:gpl3+))))
 
+(define-public emacs-prism
+  (package
+    (name "emacs-prism")
+    (version "0.3.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+		    (url "https://github.com/alphapapa/prism.el")
+		    (commit version)))
+              (sha256
+               (base32
+                "0n2gf7302hqdnhsax1y3ahksfmmpd8cmiv1zgb7rjg8qhcs0iqp2"))))
+    (build-system emacs-build-system)
+    (inputs (list emacs-dash))
+    (home-page "https://github.com/alphapapa/prism.el")
+    (synopsis
+     "Disperses Lisp forms (and other languages) into a spectrum of color by depth")
+    (description
+     "Prism is a Rainbow Blocks-like mode for Emacs. It preserves non-color
+face properties and allows configuration of faces and colors.")
+    (license license:gpl3+)))
+
 (define-public emacs-project
   (package
     (name "emacs-project")