[bug#76378] gnu: Add twitch-hls-client

Message ID 9s-pMpWdqwXSUTEGDwTVDNITfO3T2_iZnEX25cYFxSIJfTI66KYyLQvmJuYrMPF-ePRNY01RgQgl3Axyre70kGcBZX7knsJmpQOfz5D8n1Y=@proton.me
State New
Headers
Series [bug#76378] gnu: Add twitch-hls-client |

Commit Message

Vitor Hugo Feb. 17, 2025, 11:12 p.m. UTC
  * gnu/packages/rust-apps.scm (twitch-hls-client): New variable.

Change-Id: I5cf9b3e199068f5a37ae598cf14ba26be4cf8c05                                                                                                                                                                                                                           
---                                                                                                                                                                                                                                                                            
 gnu/packages/rust-apps.scm | 29 +++++++++++++++++++++++++++++                                                                                                                                                                                                                 
 1 file changed, 29 insertions(+)                                                                                                                                                                                                                                              
                                                                                                                                                                                                                                                                               
--                                                                                                                                                                                                                                                                             
2.46.0
  

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm                                                                                                                                                                                                           
index 054a09c47d..65f2d097b0 100644                                                                                                                                                                                                                                            
--- a/gnu/packages/rust-apps.scm                                                                                                                                                                                                                                               
+++ b/gnu/packages/rust-apps.scm                                                                                                                                                                                                                                               
@@ -4298,6 +4298,35 @@  (define-public tealdeer                                                                                                                                                                                                                                 
 Full featured offline client with caching support.")                                                                                                                                                                                                                          
     (license (list license:expat license:asl2.0))))                                                                                                                                                                                                                           
                                                                                                                                                                                                                                                                               
+(define-public twitch-hls-client                                                                                                                                                                                                                                              
+  (package                                                                                                                                                                                                                                                                    
+    (name "twitch-hls-client")                                                                                                                                                                                                                                                
+    (version "1.3.13")                                                                                                                                                                                                                                                        
+    (source (origin                                                                                                                                                                                                                                                           
+             (method git-fetch)                                                                                                                                                                                                                                               
+             (uri (git-reference                                                                                                                                                                                                                                              
+                   (url "https://github.com/2bc4/twitch-hls-client")                                                                                                                                                                                                          
+                   (commit version)))                                                                                                                                                                                                                                         
+             (file-name (git-file-name name version))                                                                                                                                                                                                                         
+             (sha256                                                                                                                                                                                                                                                          
+              (base32 "0nh2lqb41z7h0ak946nqbm6n3igj2rlpl6dkljlnhi3hf6lkm3hz"))))                                                                                                                                                                                              
+    (build-system cargo-build-system)                                                                                                                                                                                                                                         
+    (arguments                                                                                                                                                                                                                                                                
+     `(#:install-source? #f                                                                                                                                                                                                                                                   
+       #:cargo-inputs                                                                                                                                                                                                                                                         
+       (("rust-anyhow" ,rust-anyhow-1)                                                                                                                                                                                                                                        
+       ("rust-chunked-transfer" ,rust-chunked-transfer-1)                                                                                                                                                                                                                     
+       ("rust-flate2" ,rust-flate2-1)                                                                                                                                                                                                                                         
+       ("rust-getrandom" ,rust-getrandom-0.2)                                                                                                                                                                                                                                 
+       ("rust-pico-args" ,rust-pico-args-0.5)                                                                                                                                                                                                                                 
+       ("rust-rustls" ,rust-rustls-0.23)                                                                                                                                                                                                                                      
+       ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.7)                                                                                                                                                                                                             
+       ("rust-log" ,rust-log-0.4))))                                                                                                                                                                                                                                          
+    (home-page "https://github.com/2bc4/twitch-hls-client")                                                                                                                                                                                                                   
+    (synopsis "Command line client for Twitch.tv")                                                                                                                                                                                                                            
+    (description "twitch-hls-client is a minimal command line client for watching/recording Twitch streams")                                                                                                                                                                  
+    (license license:gpl3)))                                                                                                                                                                                                                                                  
+                                                                                                                                                                                                                                                                              
 (define-public git-absorb                                                                                                                                                                                                                                                     
   (package                                                                                                                                                                                                                                                                    
     (name "git-absorb")