diff mbox series

[bug#58208,7/7] gnu: Add nnls-chroma.

Message ID 9ffc498b9fcafdacf9625c2215b617537211ccb9.1664583143.git.lilah@lunabee.space
State New
Headers show
Series Add Sonic Visualiser and VAMP plugins. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Lilah Tascheter Oct. 1, 2022, 12:22 a.m. UTC
* gnu/packages/audio.scm (nnls-chroma): New variable.
---
 gnu/packages/audio.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

Comments

\( Oct. 27, 2022, 7:11 p.m. UTC | #1
On Sat Oct 1, 2022 at 1:22 AM BST, Lilah Tascheter via Guix-patches via wrote:
> +              (uri (string-append
> +                     "https://code.soundsoftware.ac.uk/attachments/download/"
> +                     "1691/nnls-chroma-1.1.tar.gz"))

Add file-name.

> +              (sha256
> +                (base32
> +                  "06n66ff4w4a07rfz1kn0hq2g953dsx8a4cx1bhpvswqds1kb70md"))))

One space indents...

> +    (arguments
> +     `(#:tests? #f ;; no tests available
> +       #:make-flags
> +       (list "-f" "Makefile.linux"
> +             (string-append "CC=" ,(cc-for-target))
> +             (string-append "VAMP_SDK_DIR=" (assoc-ref %build-inputs "vamp")
> +                            "/include/vamp-sdk"))
> +       #:phases
> +       ,#~(modify-phases %standard-phases
> +            (delete 'configure) ;; no configure phase
> +            (replace 'install ;; no install phase
> +              (lambda _
> +                (let ((outdir (string-append #$output "/lib/vamp"))
> +                      (outfile "nnls-chroma.so"))
> +                  (mkdir-p outdir)
> +                  (copy-file outfile (string-append outdir "/" outfile))))))))

Modernised,

  (arguments
   (list #:tests? #f ;no tests
         #:make-flags
         #~(list "-f" "Makefile.linux"
                 (string-append "CC=" #$(cc-for-target))
                 (string-append "VAMP_SDK_DIR="
                                #$(this-package-input vamp)
                                "/include/vamp-sdk"))
         #:phases
         #~(modify-phases %standard-phases
             (delete 'configure) ;no configure script
             (replace 'install
               (lambda _
                 (install-file "nnls-chroma.so"
                               (string-append #$output
                                              "/lib/vamp")))))))

> +    (native-search-paths
> +      (list (search-path-specification
> +              (variable "VAMP_PATH")
> +              (files '("lib/vamp")))))

Actually, on second thought, I don't think this is necessary for
VAMP *plugins*, only VAMP itself? (Not certain though.)

> +    (home-page "http://www.isophonics.net/nnls-chroma/")

home-page goes before synopsis :)

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 198e3cb7e8..c9a7829236 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5942,6 +5942,49 @@  (define-public vamp-aubio-plugins
     (home-page "https://aubio.org/vamp-aubio-plugins/")
     (license license:gpl3+)))
 
+(define-public nnls-chroma
+  (package
+    (name "nnls-chroma")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              ;; These urls have an "attachment number" :/ which makes this url
+              ;; not generalizable across versions.
+              (uri (string-append
+                     "https://code.soundsoftware.ac.uk/attachments/download/"
+                     "1691/nnls-chroma-1.1.tar.gz"))
+              (sha256
+                (base32
+                  "06n66ff4w4a07rfz1kn0hq2g953dsx8a4cx1bhpvswqds1kb70md"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ;; no tests available
+       #:make-flags
+       (list "-f" "Makefile.linux"
+             (string-append "CC=" ,(cc-for-target))
+             (string-append "VAMP_SDK_DIR=" (assoc-ref %build-inputs "vamp")
+                            "/include/vamp-sdk"))
+       #:phases
+       ,#~(modify-phases %standard-phases
+            (delete 'configure) ;; no configure phase
+            (replace 'install ;; no install phase
+              (lambda _
+                (let ((outdir (string-append #$output "/lib/vamp"))
+                      (outfile "nnls-chroma.so"))
+                  (mkdir-p outdir)
+                  (copy-file outfile (string-append outdir "/" outfile))))))))
+    (inputs (list boost vamp))
+    (native-search-paths
+      (list (search-path-specification
+              (variable "VAMP_PATH")
+              (files '("lib/vamp")))))
+    (synopsis "VAMP plugins for audio transcription")
+    (description "A set of three VAMP plugins used for audio transcription: NNLS
+Chroma, providing chromatic transcription, Chordino, providing chord
+transcription, and Tuning, which estimates local and global tuning.")
+    (home-page "http://www.isophonics.net/nnls-chroma/")
+    (license license:gpl2+)))
+
 (define-public sonic-visualiser
   (package
     (name "sonic-visualiser")