[bug#76324,5/6] gnu: sync: add seadrive-fuse

Message ID 9f25faeb1ebc700e4b97e98a608405f9142c55db.1739648316.git.flypaper@disroot.org
State New
Headers
Series Add seafile-client, seadrive-fuse, seadrive-client and dependencies |

Commit Message

flypaper Feb. 16, 2025, 9:38 a.m. UTC
  * gnu/packages/sync.scm (seadrive-fuse): New package.

Change-Id: I2a2855656e4cc3783ead70f6fe7793c7289b316d
---
 gnu/packages/sync.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
  

Patch

diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index a5dfa17afd..6f09ae20b2 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -771,3 +771,40 @@  (define-public seafile-client-qt5
                ,flags))
        ((#:tests? x)
         #t)))))
+
+(define-public seadrive-fuse
+  (package
+    (name "seadrive-fuse")
+    (home-page "https://github.com/haiwen/seadrive-fuse")
+    (version "2.0.28")
+    (source
+     (origin
+       (method git-fetch)
+       (file-name (git-file-name name version))
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0z8j8a04qi01cxbgk5kdrjzff5j2kigf0v6yzklvrshyb1jk3j5p"))))
+    (build-system gnu-build-system)
+    (inputs (list sqlite
+                  gtk
+                  curl
+                  util-linux
+                  openssl
+                  jansson
+                  libevent
+                  fuse-2
+                  libwebsockets
+                  libsearpc
+                  python))
+    (native-inputs (list autoconf
+                         automake
+                         libtool
+                         pkg-config
+                         vala
+                         intltool))
+    (synopsis "Mount Seafile libraries as FUSE drive")
+    (description
+     "This package provides the @{seadrive} command, allowing for seadrive libraries to be mounted as FUSE drive.")
+    (license license:gpl3+)))