diff mbox series

[bug#54186] gnu: Add python-mathlibtools.

Message ID 9f0d87a873eb4abdf541a7800c08418ec770416d.camel@courrier.dev
State Accepted
Headers show
Series [bug#54186] gnu: Add python-mathlibtools. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pradana Adrinusa AUMARS Feb. 27, 2022, 3:44 p.m. UTC
From da48bcdbc08c795fff77c1aed9b6d64192a699e3 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Sun, 27 Feb 2022 16:41:58 +0100
Subject: [PATCH] gnu: Add python-mathlibtools.

* gnu/packages/lean.scm (python-mathlibtools): New variable.
---
 gnu/packages/lean.scm | 46 ++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 45 insertions(+), 1 deletion(-)

mathlib.")
+   (license license:asl2.0)))

Comments

Ludovic Courtès March 16, 2022, 2:26 p.m. UTC | #1
Hi,

Pradana Adrinusa AUMARS <paumars@courrier.dev> skribis:

>>From da48bcdbc08c795fff77c1aed9b6d64192a699e3 Mon Sep 17 00:00:00 2001
> From: Pradana AUMARS <paumars@courrier.dev>
> Date: Sun, 27 Feb 2022 16:41:58 +0100
> Subject: [PATCH] gnu: Add python-mathlibtools.
>
> * gnu/packages/lean.scm (python-mathlibtools): New variable.

Applied.  I passed it through ‘guix style’ and expounded the description
a little bit.

> +					  (lambda _
> +					    (setenv "HOME"
> "/tmp"))))))

BTW, the message got mangled on its way (most likely the email client
split long lines, as in the example above).  Please use ‘git send-email’
or send them as attachment in the future:

  https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html

Thanks you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/lean.scm b/gnu/packages/lean.scm
index 6ac7f1668a..b959039e22 100644
--- a/gnu/packages/lean.scm
+++ b/gnu/packages/lean.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,9 +22,17 @@ 
 (define-module (gnu packages lean)
   #:use-module (gnu packages multiprecision)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system python)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
-  #:use-module (guix git-download))
+  #:use-module (guix git-download)
+  #:use-module (guix download)
+  #:use-module (gnu packages graphviz)
+  #:use-module (gnu packages version-control)
+  #:use-module (gnu packages python-build)
+  #:use-module (gnu packages python-crypto)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages python-xyz))
 
 (define-public lean
   (package
@@ -72,3 +81,38 @@  (define-public lean
 core based on dependent typed theory, aiming to bridge the gap between
 interactive and automated theorem proving.")
     (license license:asl2.0)))
+
+(define-public python-mathlibtools
+  (package
+   (name "python-mathlibtools")
+   (version "1.1.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri "mathlibtools" version))
+     (sha256
+      (base32
+       "089pql105imx8z7ar1wiz9fn000jp6xqdfixw4jf2vric94vn9fj"))))
+   (build-system python-build-system)
+   (arguments
+    '(#:phases (modify-phases %standard-phases
+			      (add-before 'check 'fix-home-directory
+					  (lambda _
+					    (setenv "HOME"
"/tmp"))))))
+   (inputs
+    (list python-toml
+	  python-pygithub
+	  python-certifi
+	  python-gitpython
+	  python-requests
+	  python-click
+	  python-tqdm
+	  python-networkx
+	  python-pydot
+	  python-pyyaml
+	  python-atomicwrites))
+   (home-page "https://github.com/leanprover-community/mathlib-tools")
+   (synopsis "Development tools for Lean mathlib")
+   (description
+    "This package contains leanproject, a supporting tool for Lean