diff mbox series

[bug#50023] gnu: Add ocaml-ppx-tools.

Message ID 9eeac32f98b481ab7ebd625bbb099e7780e3291a.1628774977.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#50023] gnu: Add ocaml-ppx-tools. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Aug. 12, 2021, 1:31 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-tools): New variable.
(ocaml4.07-ppx-tools): Remove variable.
---
‘ocaml4.07-ppx-tools’ isn’t needed by any package, so I removed it.

 gnu/packages/ocaml.scm | 25 ++++++++++++++-----------
 1 file changed, 14 insertions(+), 11 deletions(-)


base-commit: e6388b48f3df21b792cd61f93fddc7274238bac6

Comments

Julien Lepiller Oct. 8, 2021, 11:19 a.m. UTC | #1
Pushed to master as 6e29cd1f452922a3c625315fe83fb3803b737f54, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 112751ddec..583469dd21 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2262,10 +2262,10 @@  displayed at the end of the run (with the full logs ready to inspect), with a
 simple (yet expressive) query language to select the tests to run.")
     (license license:isc)))
 
-(define-public ocaml4.07-ppx-tools
+(define-public ocaml-ppx-tools
   (package
-    (name "ocaml4.07-ppx-tools")
-    (version "5.1+4.06.0")
+    (name "ocaml-ppx-tools")
+    (version "6.4")
     (source
      (origin
        (method git-fetch)
@@ -2273,18 +2273,21 @@  simple (yet expressive) query language to select the tests to run.")
              (url "https://github.com/alainfrisch/ppx_tools")
              (commit version)))
        (file-name (git-file-name name version))
-       (sha256 (base32
-                "1ww4cspdpgjjsgiv71s0im5yjkr3544x96wsq1vpdacq7dr7zwiw"))))
-    (build-system ocaml-build-system)
+       (sha256
+        (base32
+         "15v7yfv6gyp8lzlgwi9garz10wpg34dk4072jdv19n6v20zfg7n1"))))
+    (build-system dune-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases (delete 'configure))
-       #:tests? #f
-       #:ocaml ,ocaml-4.07
-       #:findlib ,ocaml4.07-findlib))
+     ;; No tests
+     `(#:tests? #f))
+    (native-inputs
+     `(("ocaml-cppo" ,ocaml-cppo)))
     (properties `((upstream-name . "ppx_tools")))
     (home-page "https://github.com/alainfrisch/ppx_tools")
     (synopsis "Tools for authors of ppx rewriters and other syntactic tools")
-    (description "Tools for authors of ppx rewriters and other syntactic tools.")
+    (description
+     "This Ocaml package provides tools for authors of ppx rewriters and other
+syntactic tools.")
     (license license:expat)))
 
 (define-public ocaml-react