diff mbox series

[bug#72219,32/34] gnu: Add python-glue-core.

Message ID 9ee20ccf056c7477a428d99f6659888a297ac4dc.1721514687.git.sharlatanus@gmail.com
State New
Headers show
Series Astronomy update 2024/07 | expand

Commit Message

Sharlatan Hellseher July 20, 2024, 10:40 p.m. UTC
* gnu/packages/astronomy.scm (python-glue-core): New variable.

Change-Id: I7fde0a36e35bf30e42cc419fdf4573a3924e032d
---
 gnu/packages/astronomy.scm | 45 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 307d85578f..df9f50285f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1147,6 +1147,51 @@  (define-public ginga-qt5
        (prepend python-pyqt)))
     (synopsis "Qt5 image viewer build based on python-ginga library")))
 
+(define-public python-glue-core
+  (package
+    (name "python-glue-core")
+    (version "1.21.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "glue_core" version))
+       (sha256
+        (base32 "1xms896ds70sbym1cr5lrbjl4i8vixy3mcc6qsg1b3ppvky76vmn"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list ;; python-astrodendro ; optional, not packed
+           python-astropy
+           python-dill
+           python-echo
+           python-fast-histogram
+           python-ipython
+           python-matplotlib
+           python-mpl-scatter-density
+           python-numpy
+           python-openpyxl
+           python-pandas
+           ;; python-pyavm ; optional, not packed
+           python-scikit-image
+           python-scipy
+           python-setuptools
+           python-shapely
+           python-spectral-cube
+           python-xlrd))
+    (native-inputs
+     (list python-h5py
+           python-objgraph
+           python-pytest
+           python-pytest-cov
+           python-pytest-mpl
+           python-setuptools
+           python-setuptools-scm))
+    (home-page "http://glueviz.org")
+    (synopsis "Multidimensional data visualization project")
+    (description
+     "Glue is a python project to link visualizations of scientific datasets
+across many files.")
+    (license license:bsd-3)))
+
 (define-public wcslib
   (package
     (name "wcslib")