diff mbox series

[bug#73549,3/4] gnu: Add fcitx5-chewing.

Message ID 9ec2e750f07696f89eadb463fb7001f939e23f17.1727596132.git.efraim@flashner.co.il
State New
Headers show
Series Update libchewing and add fcitx5 and ibus packages | expand

Commit Message

Efraim Flashner Sept. 29, 2024, 7:55 a.m. UTC
From: Charles <charles@charje.net>

* gnu/packages/fcitx5.scm (fcitx5-chewing): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Change-Id: I27cd2d9732ad12a387ecaa258a36f7342d438ab1
---
 gnu/packages/fcitx5.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index c4c2b565db7..b6002f8023c 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
 ;;; Copyright © 2022 dan <i@dan.games>
 ;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Charles <charles@charje.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -41,6 +42,7 @@  (define-module (gnu packages fcitx5)
   #:use-module (gnu packages ibus)
   #:use-module (gnu packages iso-codes)
   #:use-module (gnu packages kde-frameworks)
+  #:use-module (gnu packages language)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
@@ -369,6 +371,35 @@  (define-public fcitx5-anthy
 the Anthy input method.")
     (license license:gpl2+)))
 
+(define-public fcitx5-chewing
+  (package
+    (name "fcitx5-chewing")
+    (version "5.1.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/fcitx/fcitx5-chewing")
+                    (commit version)))
+              (sha256
+               (base32 "011psyvvcbrw062zw807lm33n827qza7mqaagf8zb0cz3hh1qwm9"))
+              (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'pre-check
+                 (lambda _ (setenv "HOME" (getcwd)))))))
+    (inputs (list libchewing))
+    (native-inputs
+     (list extra-cmake-modules
+           pkg-config
+           gettext-minimal
+           fcitx5))
+    (home-page "https://github.com/fcitx/fcitx5-chewing")
+    (synopsis "Chewing wrapper for Fcitx")
+    (description "This provides libchewing input method support for fcitx5.")
+    (license license:gpl2+)))
+
 (define-public fcitx5-chinese-addons
   (package
     (name "fcitx5-chinese-addons")